Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 129263 - Show Annotations does not work
Show Annotations does not work
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P2 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 11:34 UTC by Jan Lahoda
Modified: 2008-03-05 19:50 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Exceptions. (3.10 KB, text/plain)
2008-03-05 11:35 UTC, Jan Lahoda
Details
stderr (451 bytes, text/plain)
2008-03-05 11:36 UTC, Jan Lahoda
Details
stdout (2.42 KB, text/plain)
2008-03-05 11:36 UTC, Jan Lahoda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Lahoda 2008-03-05 11:34:45 UTC
Build (from Hudson):
Product Version: NetBeans IDE Dev (Build 20080303072759)
Java: 1.6.0_10-ea; Java HotSpot(TM) Client VM 11.0-b11
System: Linux version 2.6.20-16-generic running on i386; UTF-8; en_US (nb)
Userdir: /usr/local/home/lahvac/userdir.nball.merge

Each time I try to Show Annotations for a file (inside my NB repository), it ends up with the attached exceptions, and
no revisions are show in the "annotations stripe".

This is probably because my hg command prints some "informational" messages before it performs the given command. But,
these messages seem to go to stderr, and the useful output (i.e. annotated file) goes to stdout, so it shouldn't be
problem. I am also attaching stderr and stdout from hg annotate on a file.
Comment 1 Jan Lahoda 2008-03-05 11:35:19 UTC
Created attachment 57798 [details]
Exceptions.
Comment 2 Jan Lahoda 2008-03-05 11:36:15 UTC
Created attachment 57799 [details]
stderr
Comment 3 Jan Lahoda 2008-03-05 11:36:30 UTC
Created attachment 57800 [details]
stdout
Comment 4 novakm 2008-03-05 11:41:14 UTC

*** This issue has been marked as a duplicate of 129121 ***
Comment 5 Jan Lahoda 2008-03-05 12:16:47 UTC
novakm: are you absolutely positive this is a dupe of issue #129121?
Comment 6 novakm 2008-03-05 12:31:47 UTC
Well, show annotations action does not work in any versioning system now, it was identified as a regression so I thought
it is the cause of this issue. Most probably you are right that the exception is not connected with #129121. However,
not displaying annotations at all definitely is. I would recommend to test after #129121 is fixed and reopen if the
problem is still present.
Comment 7 John Rice 2008-03-05 12:52:24 UTC
AnnotateAction.toAnnotateLines() was changed to use regexp and make it a lot more robust, the same needs to be done for
AnnotateAction.toHgLogMessages(), to avoid these exceptions.

So will reopen this one to track the necessary changes.
Comment 8 John Rice 2008-03-05 19:50:23 UTC
Changes pushed:

changeset:   70190:211b58f3dc2d
user:        jrice@netbeans.org
date:        Wed Mar 05 13:56:08 2008 +0000
files:       mercurial/src/org/netbeans/modules/mercurial/ui/annotate/AnnotateAction.java
mercurial/src/org/netbeans/modules/mercurial/ui/annotate/AnnotationBar.java
mercurial/src/org/netbeans/modules/mercurial/ui/log/HgLogMessage.java
mercurial/src/org/netbeans/modules/mercurial/util/HgLogMessage.java
description:
#129263: rework annotation code to share common HgCommand getLogMesssages


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo