Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 129192 - Silent install not silent if there is a problem
Silent install not silent if there is a problem
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: NBI
6.x
All All
: P2 (vote)
: 6.x
Assigned To: dlipin
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 22:13 UTC by df3491
Modified: 2008-03-05 14:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description df3491 2008-03-04 22:13:42 UTC
Silent install of Netbeans 6.0 isn't always silent.  If there is a problem with the install,
a window may pop up.  If the window can't pop up, the installer is silent, but nothing gets
installed.

To reproduce:
1) netbeans-6.0-cpp-solaris-sparc.sh --record state.xml
2) rm -rf netbeans-6.0
3) netbeans-6.0-cpp-solaris-sparc.sh --silent --state state.xml
4) if $DISPLAY is set:
      A window pops up saying:
         Validation problem
         It seems that the installation of Base IDE is corrupted.
         ...
      (this is not silent!)
   if $DISPLAY is not set:
      the installer exits without installing and no message that the install failed,
      but at least the command returns a non-zero exit status.

I don't know if there are other error conditions that act this way, or if they would cause
problems should the install proceed, but for this particular problem, I think it would be
okay to go ahead and install silently.
Comment 1 dlipin 2008-03-05 12:57:00 UTC
yes, we do have such a problem...
Comment 2 dlipin 2008-03-05 13:22:32 UTC
David,

Yes, there is bunch of problems when such UI warning will show.
I can`t personally say what should be the default action (exit or continue) in each case..
The most frequent are the following:
1) The installer lock file exists. This could occur in two cases : 
a) another instance of the installer is running at the same moment
b) the previous running installer instance was terminated abnormally e.g. using task manager or kill command
I guess to treat such a case as a critical and exit with non-zero code. (user can always add --ignore-lock to disable 
that check)

2) Installation data (~/.nbi/registry.xml) is somehow corrupted (truncated or similar).
This case I will also treat as critical and installer will exit in that case

3) User deleted installation data (~/.nbi) and then invoked the uninstaller.
In such a case uninstallation can`t proceed since there not enough information for doing that.
The default action is the same - exit.

4) Installation validation (the case you described).
I tend to think that in such a case the installation can be continued (it is not clear what to do with rear cases such 
as described in Issue 111220).

If you have any objections/suggestions - pls let me know.
Comment 3 dlipin 2008-03-05 14:29:51 UTC
Hopefully fixed now in development builds.
http://hg.netbeans.org/main/rev/411b49aaba25

David, feel free to add comments/questions/suggestions.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo