Bug 12915 - org.openide.filesystems.FileStateInvalidException: null
org.openide.filesystems.FileStateInvalidException: null
Status: CLOSED FIXED
Product: javaee
Classification: Unclassified
Component: Code
-FFJ-
PC Windows ME/2000
: P1 (vote)
: 3.x
Assigned To: Damian Frach
issues@javaee
:
: 14031 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-16 16:12 UTC by Arjuna Chala
Modified: 2003-07-02 08:31 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arjuna Chala 2001-06-16 16:12:57 UTC
The error occurs when debugging a servlet. I am using the JSP and Servlet 
development modules installed from the update center.

Steps to reproduce the problem:-

1. Add a web module to  a project.
2. Add a servlet(e.g. TestServlet.java) to the web-inf\classes directory.
3. Try to debug (F5)

View stack trace:-

Sat Jun 16 10:53:06 PDT 2001: 
org.openide.filesystems.FileStateInvalidException: null
org.openide.filesystems.FileStateInvalidException
        at org.openide.filesystems.AbstractFileObject$Invalid.getFileSystem
(AbstractFileObject.java:784)
        at org.netbeans.modules.web.webdata.WebDataFactoryImpl.findDataObject
(WebDataFactoryImpl.java:112)
        at org.netbeans.modules.web.webdata.WebDataFactoryImpl.findResource
(WebDataFactoryImpl.java:95)
        at 
org.netbeans.modules.web.core.jsploader.JspCompileUtil.getResourceData
(JspCompileUtil.java:92)
        at org.netbeans.modules.web.core.jsploader.CompileData.<init>
(CompileData.java:56)
        at org.netbeans.modules.web.core.jsploader.JspDataObject.getPlugin
(JspDataObject.java:437)
        at 
org.netbeans.modules.web.core.jsploader.JspDataObject.getServletDataObject
(JspDataObject.java:459)
        at 
org.netbeans.modules.web.core.jsploader.JspServletDataObject$ServletEditorCookie
.currentEditorCookie(JspServletDataObject.java:171)
        at 
org.netbeans.modules.web.core.jsploader.JspServletDataObject$ServletEditorCookie
.getLineSet(JspServletDataObject.java:182)
        at org.netbeans.modules.debugger.support.util.Utils.getLineSet
(Utils.java:393)
        at org.netbeans.modules.debugger.support.util.Utils.getLine
(Utils.java:343)
        at 
org.netbeans.modules.debugger.support.LineBreakpointEvent.setLineNumber
(LineBreakpointEvent.java:231)
        at org.netbeans.modules.debugger.jpda.LineBreakpoint$2.setValue
(LineBreakpoint.java:125)
        at 
org.netbeans.modules.debugger.multisession.SessionBreakpoint.synchronizeProperti
es(SessionBreakpoint.java:173)
        at 
org.netbeans.modules.debugger.multisession.SessionBreakpoint.addEventForDebugger
(SessionBreakpoint.java:196)
        at 
org.netbeans.modules.debugger.multisession.SessionBreakpoint.addDebugger
(SessionBreakpoint.java:206)
        at 
org.netbeans.modules.debugger.multisession.EnterpriseDebugger.addEvents
(EnterpriseDebugger.java:663)
        at 
org.netbeans.modules.debugger.multisession.EnterpriseDebugger.debugerRunning
(EnterpriseDebugger.java:628)
        at 
org.netbeans.modules.debugger.multisession.EnterpriseDebugger$SessionListener.pr
opertyChange(EnterpriseDebugger.java:769)
        at java.beans.PropertyChangeSupport.firePropertyChange
(PropertyChangeSupport.java:152)
        at 
org.netbeans.modules.debugger.support.DebuggerSupport.firePropertyChange
(DebuggerSupport.java:421)
        at org.netbeans.modules.debugger.support.DebuggerSupport.setState
(DebuggerSupport.java:160)
        at org.netbeans.modules.debugger.jpda.JPDADebugger.setState
(JPDADebugger.java:1083)
        at org.netbeans.modules.debugger.jpda.JPDADebugger.startDebugger
(JPDADebugger.java:909)
        at org.netbeans.modules.debugger.jpda.JPDADebugger.startDebugger
(JPDADebugger.java:232)
        at 
org.netbeans.modules.debugger.multisession.EnterpriseDebugger.startSession
(EnterpriseDebugger.java:358)
        at 
org.netbeans.modules.debugger.multisession.EnterpriseDebugger.startDebugger
(EnterpriseDebugger.java:180)
        at 
org.netbeans.modules.j2ee.impl.DefaultServerInstanceManager.startDebugger
(DefaultServerInstanceManager.java:151)
        at 
org.netbeans.modules.j2ee.impl.DefaultServerInstanceManager.serverInstanceStartD
ebugging(DefaultServerInstanceManager.java:89)
        at org.netbeans.modules.j2ee.impl.DefaultExecPerformer.startDebugging
(DefaultExecPerformer.java:78)
        at org.netbeans.modules.j2ee.impl.ServerDebuggerType.startDebugger
(ServerDebuggerType.java:44)
        at org.netbeans.modules.j2ee.impl.ServerDebuggerType.startDebugger
(ServerDebuggerType.java:38)
        at org.openide.loaders.ExecSupport.debug(ExecSupport.java:116)
[catch] at org.openide.actions.DebuggerPerformer$StartDebugThread.run
(DebuggerPerformer.java:338)
Comment 1 David Jarrin 2001-06-18 19:44:31 UTC
The same error exception is thrown following these steps,

 

- Create a new JSP using the IDE's "New" menu steps, as usual

- Right-click on the newly created file... The normal context menu pops up 
without errors. 

- Rename or copy/paste the JSP to have a different name.

- Right-click on the newly renamed/pasted file... A FileStateInvalidException 
is thrown.
Comment 2 Petr Jiricka 2001-06-19 14:48:09 UTC
Fixed on June 19, 2001
Comment 3 Damian Frach 2001-08-03 10:15:31 UTC
*** Issue 14031 has been marked as a duplicate of this issue. ***
Comment 4 Quality Engineering 2003-07-02 08:31:20 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo