Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 129132 - IllegalArgumentException: Error generated in parsing
IllegalArgumentException: Error generated in parsing
Status: RESOLVED DUPLICATE of bug 127252
Product: obsolete
Classification: Unclassified
Component: Registration
6.x
All All
: P2 (vote)
: 6.x
Assigned To: mslama
issues@platform
http://statistics.netbeans.org/except...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 13:44 UTC by Lukas Hasik
Modified: 2008-11-13 00:17 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2008-03-04 13:44:13 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows XP, 5.1, x86
User comments: Recent Automatically update netbeans and plataform
STACKTRACE: (first 10 lines)
java.lang.IllegalArgumentException: Error generated in parsing
        at com.sun.servicetag.RegistrationDocument.initializeDocument(RegistrationDocument.java:164)
        at com.sun.servicetag.RegistrationDocument.load(RegistrationDocument.java:115)
        at com.sun.servicetag.RegistrationData.loadFromXML(RegistrationData.java:426)
        at org.netbeans.modules.reglib.NbServiceTagSupport.getRegistrationData(NbServiceTagSupport.java:373)
        at org.netbeans.modules.reglib.NbServiceTagSupport.getNbServiceTag(NbServiceTagSupport.java:453)
        at org.netbeans.modules.reglib.NbServiceTagSupport.createNbServiceTag(NbServiceTagSupport.java:171)
        at org.netbeans.modules.registration.NbInstaller.restored(NbInstaller.java:98)
        at org.netbeans.core.startup.NbInstaller.loadCode(NbInstaller.java:378)
        at org.netbeans.core.startup.NbInstaller.load(NbInstaller.java:297)
        at org.netbeans.ModuleManager.enable(ModuleManager.java:933)
Comment 1 Exceptions Reporter 2008-03-09 05:46:34 UTC
This issue has already 50 duplicates 
Comment 2 Lukas Hasik 2008-03-10 09:18:47 UTC
thompsonwd40, thegreatestmale, could please look for registration.xml file in your NB_INSTALL_DIR?

thank you
Comment 3 thompsonwd40 2008-03-10 14:51:08 UTC
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<registration_data version="1.0">
   <environment>
      <hostname>79J1Y91HR</hostname>
      <hostId/>
      <osName>Windows XP</osName>
      <osVersion>5.1</osVersion>
      <osArchitecture>x86</osArchitecture>
      <systemModel>Latitude D610</systemModel>
      <systemManufacturer>Dell Inc.</systemManufacturer>
      <cpuManufacturer>GenuineIntel</cpuManufacturer>
      <serialNumber>79J1Y91</serialNumber>
   </environment>
   <registry urn="urn:st:01d710cd-2d80-4be0-a4cb-97c4ecc7a181" version="1.0">
      <service_tag>
         <instance_urn>urn:st:4ddc4cfe-b4bc-4e94-99a5-79fc90e08881</instance_urn>
         <product_name>NetBeans Integrated Development Environment 6.0.1</product_name>
         <product_version>6.0.1</product_version>
         <product_urn>urn:uuid:9f26b64c-a4f1-11dc-8f02-080020a9ed93</product_urn>
         <product_parent_urn>urn:uuid:bc76c157-8a3c-4da7-97d2-41d561ffe234</product_parent_urn>
         <product_parent>Development Tools</product_parent>
         <product_defined_inst_id>id=6.0.1,dir=C:\Program Files\NetBeans
6.0.1,java.version=1.6.0_03</product_defined_inst_id>
         <product_vendor>NetBeans.org</product_vendor>
         <platform_arch>x86</platform_arch>
         <timestamp>2008-02-21 16:37:28 GMT</timestamp>
         <container>global</container>
         <source>NetBeans IDE 6.0.1 Installer</source>
         <installer_uid>-1</installer_uid>
      </service_tag>
   </registry>
</registration_data>
Comment 4 mslama 2008-03-11 17:06:46 UTC

*** This issue has been marked as a duplicate of 127252 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo