Bug 129077 - [saas]DnD operation of Websvc manager Facebook & Flickr gen issues
[saas]DnD operation of Websvc manager Facebook & Flickr gen issues
Status: VERIFIED FIXED
Product: webservices
Classification: Unclassified
Component: Manager
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Ayub Khan
issues@webservices
:
: 130013 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 07:16 UTC by Ayub Khan
Modified: 2008-03-25 22:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ayub Khan 2008-03-04 07:16:38 UTC
When you DnD Facebook

1) to a POJO

Both files /src/org.netbeans.saas.facebook.FacebookService.java, /src/org.netbeans.saas.facebook.FacebookService.java
have compile issues, and 

there is a missing AuthorizationFrame.java file.

2) to a Servlet or Resource Class

Both files /src/org.netbeans.saas.facebook.FacebookService.java, /src/org.netbeans.saas.facebook.FacebookService.java
have compile issues, and

there is a missing Callback servlet class and its registration in web.xml

For Flickr service I get NPE

java.lang.NullPointerException
	at org.netbeans.modules.websvc.saas.codegen.java.model.SaasBean.findAuthentication(SaasBean.java:213)
	at org.netbeans.modules.websvc.saas.codegen.java.model.WadlSaasBean.init(WadlSaasBean.java:84)
	at org.netbeans.modules.websvc.saas.codegen.java.model.WadlSaasBean.<init>(WadlSaasBean.java:76)
	at org.netbeans.modules.websvc.saas.codegen.java.JaxRsCodeGenerator.<init>(JaxRsCodeGenerator.java:100)
	at org.netbeans.modules.websvc.saas.codegen.java.JaxRsJavaClientCodeGenerator.<init>(JaxRsJavaClientCodeGenerator.java:64)
	at org.netbeans.modules.websvc.saas.codegen.java.JaxRsCodeGeneratorFactory.create(JaxRsCodeGeneratorFactory.java:70)
	at org.netbeans.modules.websvc.saas.codegen.java.JaxRsEditorDrop$1.run(JaxRsEditorDrop.java:114)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)
Comment 1 Ayub Khan 2008-03-05 00:14:18 UTC
Issue #1 is fixed into trunk and nb61beta1 branch.

Issue #2's NPE is fixed into trunk and nb61beta1 branch.

Only outstanding issue that needs to be release noted for nb61beta1 is

============================================================
When you DnD Facebook to a Servlet or Resource Class

Both files /src/org.netbeans.saas.facebook.FacebookService.java, /src/org.netbeans.saas.facebook.FacebookService.java
have compile issues, and

there is a missing Callback servlet class and its registration in web.xml

============================================================
Comment 2 Ayub Khan 2008-03-15 03:16:46 UTC
*** Issue 130013 has been marked as a duplicate of this issue. ***
Comment 3 Ayub Khan 2008-03-17 04:15:33 UTC
Fixed for 6.1 (trunk)
Comment 4 Lukas Jungmann 2008-03-25 22:33:51 UTC
facebook seems to be OK now, for flickr there is issue 131100


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo