Bug 129002 - Ws impl class is not refreshed after submitting changes in cust. editor
Ws impl class is not refreshed after submitting changes in cust. editor
Status: RESOLVED WONTFIX
Product: webservices
Classification: Unclassified
Component: Customization
6.x
All All
: P3 (vote)
: 7.4
Assigned To: Milan Kuchtiak
issues@webservices
http://hg.netbeans.org/main/file/tip/...
: RANDOM, T9Y, TEST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-03 13:30 UTC by Lukas Jungmann
Modified: 2016-07-07 09:54 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Jungmann 2008-03-03 13:30:50 UTC
scenario:
http://wiki.netbeans.org/TS_60_CustomizationEditor#section-TS_60_CustomizationEditor-TestSuiteCustomizationOfWSDLInWebServiceFromWSDLScenario

problem:
when modified customization dialog is closed by pushing or clicking on the OK button in test, "local" wsdl is marked as
modified, dialog itself is disposed, but nothing else. There's no information dialog regarding regeneration of the ws
implementation class (as a result of this there are some outstanding non-saved changes in "local" WSDL file). This also
very rarely (<3% cases) happens in manual testing

possible causes:

- use of RequestProcessor.getDefault().post(...) (CustomizationWSEditor.java:157) - considered as performance risk
because it is not guaranteed that posted Runnable will run anytime soon; should use non-default instance of
RequestProcessor or even better java.util.concurrent.ExecutorService (OTOH problem can be somwhere else since mentioned
Runnable from CustomizationWSEditor.java actually never runs in the test)

- something what should be called in EDT is being called somwhere else

- some lost events somewhere
Comment 1 Roderico Cruz 2008-03-25 09:51:37 UTC
Will look at this in NB 6.1
Comment 2 Lukas Jungmann 2008-04-14 17:15:20 UTC
moving opened issues where TM != dev to TM=TBD
Comment 3 Lukas Jungmann 2008-10-23 22:53:49 UTC
will try to find some solution for this...
Comment 4 Milan Kuchtiak 2013-08-27 11:56:57 UTC
Yes, this scenario is still quite unreliable and, sometimes, the web services node even disapears.
Comment 5 Martin Balin 2016-07-07 09:54:20 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo