Bug 128732 - I18N - MySQL err message contains bad multibyte chars
I18N - MySQL err message contains bad multibyte chars
Status: RESOLVED WONTFIX
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: TBD
Assigned To: David Vancouvering
issues@db
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-28 17:36 UTC by kaa
Modified: 2008-04-29 16:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
image (137.54 KB, image/jpeg)
2008-02-28 17:39 UTC, kaa
Details
image1 (67.78 KB, image/jpeg)
2008-02-28 17:40 UTC, kaa
Details
image (35.28 KB, image/jpeg)
2008-04-29 16:16 UTC, kaa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaa 2008-02-28 17:38:21 UTC
Product Version: NetBeans IDE Dev (Build 200802191203)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)

Below is the extract from the list of variables of the server environment:

| character_set_client            | utf8                                                           |
| character_set_connection        | utf8                                                           |
| character_set_database          | utf8                                                           |
| character_set_filesystem        | binary                                                         |
| character_set_results           | utf8                                                           |
| character_set_server            | utf8                                                           |
| character_set_system            | utf8                                                           |
| character_sets_dir              | C:\Program Files\MySQL\MySQL Server 5.1\share\charsets\        |
| collation_connection            | utf8_general_ci                                                |
| collation_database              | utf8_general_ci                                                |
| collation_server                | utf8_general_ci

Steps:
1. Connect to My SQL server fro the IDE
2. Try to create a table using mbyte in its name
3. Try to create a table with the same name

There is an err message with bad mbyte. Probably it is expected behavior but the message shouldn't contain
bad mbyte in it. I'm running in the Japan locale, using a pseudo localized Netbeans.
Comment 1 kaa 2008-02-28 17:39:18 UTC
Created attachment 57476 [details]
image
Comment 2 kaa 2008-02-28 17:40:51 UTC
Created attachment 57477 [details]
image1
Comment 3 David Vancouvering 2008-02-28 19:09:25 UTC
This is a bug in the MySQL error message.  I don't believe it makes sense for me to disable the error message just
because there are some bad characters.  I believe in general the error message is useful.  If you want you could log a
bug with MySQL.  See http://bugs.mysql.com/
Comment 4 kaa 2008-04-29 16:15:29 UTC
I found another message. Does it related to MySQL error messages also?

If the name of a table has more then 6 multibyte chars it will be truncated by 'E' at the end and shown under the
'Tables' node. (see image) For this kind of tables delete action doesn't work and err message with square boxes appears.
Also I can't expand table node to see tables columns.
Comment 5 kaa 2008-04-29 16:16:07 UTC
Created attachment 60809 [details]
image
Comment 6 kaa 2008-04-29 16:20:13 UTC
It looks close to http://bugs.mysql.com/bug.php?id=1406


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo