Bug 128637 - JVM crash when requesting allocation stack traces
JVM crash when requesting allocation stack traces
Status: RESOLVED DUPLICATE of bug 62919
Product: profiler
Classification: Unclassified
Component: Base
6.x
PC Windows XP
: P2 (vote)
: TBD
Assigned To: issues@profiler
issues@profiler
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 22:57 UTC by _ gsporar
Modified: 2008-02-29 11:21 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
JVM log file from the crash (7.49 KB, text/plain)
2008-02-27 22:58 UTC, _ gsporar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ gsporar 2008-02-27 22:57:14 UTC
See http://www.netbeans.org/issues/show_bug.cgi?id=128635 for the setup information.  It was after I restarted the IDE
and did *not* see the problem reported in 128635 that I attempted to continue following the demo script and on step 21 I
right-clicked the entry in the Live Results for String and selected Take Snapshot and Show Allocation Stack Traces.

The profiler reported an error indicating the profiled application had terminated.  This was in the output window of the
IDE:

com.meterware.servletunit.ServletUnitHttpResponse@17f66f7]
Count: 1008[ _response = com.meterware.servletunit.ServletUnitHttpResponse@52b94e]
Count: 1009[ _response = com.meterware.servletunit.ServletUnitHttpResponse@dbace4]
Count: 1010[ _response = com.meterware.servletunit.ServletUnitHttpResponse@d8b036]
Count: 1011[ _response = com.meterware.servletunit.ServletUnitHttpResponse@d03f1f]
#
# An unexpected error has been detected by Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x10002728, pid=5048, tid=4212
#
# Java VM: Java HotSpot(TM) Client VM (10.0-b19 mixed mode windows-x86)
# Problematic frame:
# C  [profilerinterface.dll+0x2728]
#
# An error report file with more information is saved as:
# C:\docs\hol\2008\profiler\netbeansprofiler\exercises\exercise3\HttpUnit\hs_err_pid5048.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
0B759F40, *dCl = 131239184
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0B619848, *mId = 0
Profiler Agent Warning: dCl = 0B759F44, *dCl = 131147520
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0BF06DB0, *mId = 0
Profiler Agent Warning: dCl = 0B759F5C, *dCl = 130615504
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0BF06DAC, *mId = 0
Profiler Agent Warning: dCl = 0B759F5C, *dCl = 130615504
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0B619888, *mId = 0
Profiler Agent Warning: dCl = 0B759F60, *dCl = 131152912
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0B61988C, *mId = 0
Profiler Agent Warning: dCl = 0B759F64, *dCl = 131152912
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0BF06DC0, *mId = 0
Profiler Agent Warning: dCl = 0B759F9C, *dCl = 131236488
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0B6198EC, *mId = 0
Profiler Agent Warning: dCl = 0B759F9C, *dCl = 131236488
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0BF06DC4, *mId = 0
Profiler Agent Warning: dCl = 0B759F9C, *dCl = 131236488
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0B6198E8, *mId = 0
Profiler Agent Warning: dCl = 0B759F9C, *dCl = 131236488
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0BF06C34, *mId = 0
Profiler Agent Warning: dCl = 0B759FC4, *dCl = 126989968
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0BF06C38, *mId = 0
Profiler Agent Warning: dCl = 0B759FE0, *dCl = 126916088
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0B619928, *mId = 0
Profiler Agent Warning: dCl = 0B759FE4, *dCl = 126989128
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0B61992C, *mId = 0
Profiler Agent Warning: dCl = 0B759FE8, *dCl = 126624312
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0BF06C40, *mId = 0
Profiler Agent Warning: dCl = 0B75A04C, *dCl = 126990912
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0BF06C44, *mId = 0
Profiler Agent Warning: dCl = 0B75A04C, *dCl = 126990912
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0B619988, *mId = 0
Profiler Agent Warning: dCl = 0B75A06C, *dCl = 122938200
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0B61998C, *mId = 0
Profiler Agent Warning: dCl = 0B75A070, *dCl = 122938200
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0BF06CBC, *mId = 0
Profiler Agent Warning: dCl = 0B75A078, *dCl = 126703520
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0BF06CB8, *mId = 0
Profiler Agent Warning: dCl = 0B75A07C, *dCl = 122276064
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0BF06C84, *mId = 0
Profiler Agent Warning: dCl = 0B75A088, *dCl = 122692936
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0BF06C80, *mId = 0
Profiler Agent Warning: dCl = 0B75A08C, *dCl = 130626288
Profiler Agent: 250 classes cached.
Profiler Agent Warning: Invalid declaringClass obtained from jmethodID
Profiler Agent Warning: mId = 0B61A5B8, *mId = 0
Profiler Agent Warning: dCl = 00000C26
Java Result: 1
BUILD SUCCESSFUL (total time: 5 minutes 23 seconds)


I will attach hs_err_pid5048.log
Comment 1 _ gsporar 2008-02-27 22:58:06 UTC
Created attachment 57398 [details]
JVM log file from the crash
Comment 2 Tomas Hurka 2008-02-29 11:21:01 UTC
Known issue, use -Xnoclassgc

*** This issue has been marked as a duplicate of 62919 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo