Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 128635 - IDE locks up when attempting to sort by Generations
IDE locks up when attempting to sort by Generations
Status: RESOLVED DUPLICATE of bug 122139
Product: profiler
Classification: Unclassified
Component: Base
6.x
PC Windows XP
: P2 (vote)
: TBD
Assigned To: issues@profiler
issues@profiler
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 22:42 UTC by _ gsporar
Modified: 2008-02-29 15:31 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE message log (88.99 KB, text/plain)
2008-02-27 22:43 UTC, _ gsporar
Details
Thread dump taken while the IDE was non-responsive (22.24 KB, text/plain)
2008-02-27 22:43 UTC, _ gsporar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ gsporar 2008-02-27 22:42:38 UTC
Running NetBeans 6.0 (with the 6.0.1 patches, IIRC) on Windows Vista, using JDK 6 update 4.

In following this demo script: http://wiki.netbeans.org/HttpUnitCaseStudy, I run into a problem on step 16.  When I
attempt to sort by Generations, the IDE locks up.  The windows stop updating and it does not respond to mouse or
keyboard input.

If I use the Windows process manager to kill the application that is being profiled, then the IDE begins responding again.

I will attach my message log and a thread dump.
Comment 1 _ gsporar 2008-02-27 22:43:26 UTC
Created attachment 57395 [details]
IDE message log
Comment 2 _ gsporar 2008-02-27 22:43:54 UTC
Created attachment 57396 [details]
Thread dump taken while the IDE was non-responsive
Comment 3 _ gsporar 2008-02-27 22:48:05 UTC
I shut down the IDE and then restarted it.  Now I cannot reproduce the problem....  :-/
Comment 4 Tomas Hurka 2008-02-29 11:16:33 UTC
This looks to me like duplicate of issue #122139. Note that for some reason you have 6.0 version of profiler. This is grep from you IDE log:
        org.netbeans.lib.profiler/1 [1.1.1 200711261600]
        org.netbeans.lib.profiler.common/1 [1.1.1 200711261600]
        org.netbeans.lib.profiler.ui/1 [1.1.1 200711261600]
        org.netbeans.modules.profiler/1 [1.6.1 200711261600]
        org.netbeans.modules.profiler.nbmodule/1 [1.3.1 200711261600]
        org.netbeans.modules.profiler.j2ee.jboss/1 [1.3.1 200711261600]
        org.netbeans.modules.profiler.j2ee.tomcat/1 [1.3.1 200711261600]
        org.netbeans.modules.profiler.loadgen/1 [1.5 200801291616]
        org.netbeans.modules.profiler.j2ee.weblogic/1 [1.3.1 200711261600]
        org.netbeans.modules.profiler.freeform/1 [1.3.1 200711261600]
        org.netbeans.modules.profiler.j2ee/1 [1.3.1 200711261600]
        org.netbeans.modules.profiler.j2ee.sunas/1 [1.3.1 200711261600]
        org.netbeans.modules.profiler.j2se/1 [1.3.1 200711261600]



Comment 5 _ gsporar 2008-02-29 14:56:41 UTC
Okay, I have updated to the latest patches.  I will re-open this IZ or file a new one if I see the problem again.
Comment 6 Tomas Hurka 2008-02-29 15:29:54 UTC
Ok, also don't forgot to take thread dump of profiled application. Closing as dup of #122139.
Comment 7 Tomas Hurka 2008-02-29 15:31:53 UTC
closing

*** This issue has been marked as a duplicate of 122139 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo