Bug 128569 - [69cat] Support for Mercurial queues
[69cat] Support for Mercurial queues
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P2 with 3 votes (vote)
: 7.2
Assigned To: Ondrej Vrabec
issues@versioncontrol
: PLAN
: 141113 185111 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 15:04 UTC by Jan Lahoda
Modified: 2011-11-19 16:17 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Lahoda 2008-02-27 15:04:43 UTC
It would be nice if there would be support for Mercurial Queues in NetBeans:
http://www.selenic.com/mercurial/wiki/index.cgi/MqExtension
http://hgbook.red-bean.com/hgbookch12.html
http://hgbook.red-bean.com/hgbookch13.html
Comment 1 Tomas Stupka 2008-07-22 08:46:58 UTC
*** Issue 141113 has been marked as a duplicate of this issue. ***
Comment 2 Tomas Stupka 2010-04-27 15:22:25 UTC
*** Bug 185111 has been marked as a duplicate of this bug. ***
Comment 3 ulfzibis 2010-04-27 15:27:57 UTC
When working on JDK 7 sources the mq <queue> extension is in common use by
OpenJDK developers to share changes before commit.

For start examine splendid Queue support in TortoiseHG GUI.
Comment 4 Jesse Glick 2010-04-27 19:28:01 UTC
Trying to fully substitute for the command line seems unwise and a waste of effort; there are a lot of MQ commands with subtle syntax, and most are not run very commonly. But a quick way to run 'hg qrefresh' from the GUI might be helpful when working on a patch. Also a way to show `hg qdiff` in the IDE's diff viewer could be useful.

Note that http://bitbucket.org/parren/hg-pbranch/ is friendlier to an IDE: you can use plain old Commit.
Comment 5 Ondrej Vrabec 2011-11-18 11:35:31 UTC
vcs-hg-queues branch merged into trunk: http://hg.netbeans.org/core-main/file/984a429b4f71/mercurial/src/org/netbeans/modules/mercurial/ui/queues
Comment 6 Quality Engineering 2011-11-19 16:17:14 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/5ff575974e72
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #128569 - Support for Mercurial queues
go to patch, push all, pop all actions


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo