Bug 128556 - Move Down button sometimes doesn't work in Configure Handlers
Move Down button sometimes doesn't work in Configure Handlers
Status: NEW
Product: webservices
Classification: Unclassified
Component: Client
6.x
All All
: P4 (vote)
: 6.x
Assigned To: Milan Kuchtiak
issues@webservices
: RANDOM, TEST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 14:01 UTC by Jaroslav Pospisil
Modified: 2013-07-24 08:08 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Pospisil 2008-02-27 14:01:43 UTC
Build 200802270005,JDK1.6.0_05,Win Vista

Steps to reproduce:
1)Start IDE with clean userdir
2)Open websvc.kit project from hg repository
3)In projects, select Functional Test Packages > org.netbeans.modules.netbeans.qaf > WsValidation.java and in context
menu choose Run File.
4)test will proceed and ends with ComparisonFailure in test case DeployWsClientProject.

There's test on Configure Message Handlers window. Two handlers are added,one removed,three more added,second handler is
moved up, then third moved down and then test fails, because result sequence looks like last action didn't happened. 
It looks like Move Down button isn't enabled in this case, although it should or the action doesn't work.
This is random issue, although reproducible quite often on windows machines.
Comment 1 Lukas Jungmann 2008-04-14 17:14:49 UTC
moving opened issues where TM != dev to TM=TBD
Comment 2 Jaroslav Pospisil 2008-11-11 12:23:56 UTC
Not seen for a long time,closing as worksforme.
Comment 3 Lukas Jungmann 2008-11-11 14:33:37 UTC
tests can still randomly reproduce this...


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo