Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 128118 - Accessibility of New File > Modules Dev > Module Installer
Accessibility of New File > Modules Dev > Module Installer
Status: VERIFIED FIXED
Product: apisupport
Classification: Unclassified
Component: Templates
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jesse Glick
issues@apisupport
: A11Y
: 77973 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-22 10:52 UTC by Petr Chytil
Modified: 2008-02-29 08:55 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Chytil 2008-02-22 10:52:06 UTC
Product Version: NetBeans IDE Dev (Build 200802191203)
Java: 1.5.0_14; Java HotSpot(TM) Client VM 1.5.0_14-b03
System: Linux version 2.6.22-14-generic running on i386; UTF-8; en_US (nb)
Userdir: /home/petr/.netbeans/dev

File > New File > Module Developement > Module Installer > [Next] 

Missing accessible description for dialog > P1

Full output from accessibility tester:
===========================================  Tested Window title : New Module Installer
===========================================

Results of Accessibility test

Doesn't implement Accessible : - none.

No Accessible name : - none.

No Accessible description :

Class
    org.netbeans.core.windows.services.NbDialog { New Module Installer | } 

Label with LABEL_FOR not set : - none.

Components with no LABEL_FOR pointing to it : - none.

Components with no mnemonic : - none.

Components with wrong mnemonic (mnemonic isn't ASCII , label doesn't contain mnemonic): - none.

Components not reachable with tab traversal : - none.
Comment 1 Jesse Glick 2008-02-22 19:15:15 UTC
a43d90e1db3a
Comment 2 Jesse Glick 2008-02-27 19:51:03 UTC
*** Issue 77973 has been marked as a duplicate of this issue. ***
Comment 3 Lukas Hasik 2008-02-29 08:55:06 UTC
verified in 02/28 build

===============================================
 Tested Window title : New Module Installer
===============================================

Results of Accessibility test


 Doesn't implement Accessible :
   - none.

 No Accessible name :
   - none.

 No Accessible description :
   - none.

 Label with LABEL_FOR not set :
   - none.

 Components with no LABEL_FOR pointing to it :
   - none.

 Components with no mnemonic :
   - none.

 Components with wrong mnemonic (mnemonic isn't ASCII , label doesn't contain mnemonic):
   - none.

 Components not reachable with tab traversal :
   - none.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo