Bug 127826 - [PLAN6.5] Add support for Linux/PPC systems
[PLAN6.5] Add support for Linux/PPC systems
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: NBI
6.x
Macintosh Linux
: P2 (vote)
: 6.x
Assigned To: dlipin
issues@installer
: PLAN
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-20 09:56 UTC by eppesuigoccas
Modified: 2008-05-07 04:50 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description eppesuigoccas 2008-02-20 09:56:18 UTC
I have a linux box with java 1.4 and netbeans 5.0 running.
Today I updated the machine to the latest netbeans by first installign ibm jdk 1.6 (ibm-java-sdk-6.0-0.0-linux-ppc.tgz)
and then running netbeans installer this way:

$ chmod u+x netbeans-6.0.1-ml-javase-linux.sh
$ env JAVA_HOME=/usr/lib/j2sdk1.6-ibm PATH=/usr/lib/j2sdk1.6-ibm/bin:$PATH ./netbeans-6.0.1-ml-javase-linux.sh

the installer starts, write these lines of text:

Configuring the installer...
Searching for JVM on the system...
Extracting installation data...
Running the installer wizard...

then open an empty window with no title, and a second window title "Critical error". The first have the netbeans icon,
the second one the java icon. Both windows are empty.

The installer is probably waiting for something, but nothing happens. This is the process tree:

giuseppe 10341  0.2  0.2   5868  2176 pts/0    S+   10:50   0:00  |   \_ /bin/sh ./netbeans-6.0.1-ml-javase-linux.sh
giuseppe 11492  5.8  6.3 349992 66008 pts/0    Sl+  10:50   0:06  |       \_ /usr/lib/j2sdk1.6-ibm/bin/java -Xmx256m
-Xms64m -Djava.io.tmpdir=/tmp -classpath /tmp/.nbi-3025007.tmp/bundle.jar org.netbeans.installer.Installer

using --verbose argument I see this exception:

[2008-02-20 10:53:01.442]: loading jni library
[2008-02-20 10:53:01.443]:     library resource path: native/jnilib/linux/linux.so
[2008-02-20 10:53:01.491]:     library file path: /tmp/nbi-2001.tmp
[2008-02-20 10:53:01.503]:     Cannot load native library from path: native/jnilib/linux/linux.so
[2008-02-20 10:53:01.505]:     java.lang.UnsatisfiedLinkError: /tmp/nbi-2001.tmp (/tmp/nbi-2001.tmp: ELF file data
encoding not big-endian)
[2008-02-20 10:53:01.505]:     	at java.lang.ClassLoader.loadLibraryWithPath(ClassLoader.java:992)
[2008-02-20 10:53:01.506]:     	at java.lang.System.load(System.java:453)
[2008-02-20 10:53:01.506]:     	at org.netbeans.installer.utils.system.NativeUtils.loadNativeLibrary(NativeUtils.java:248)
[2008-02-20 10:53:01.506]:     	at org.netbeans.installer.utils.system.LinuxNativeUtils.<init>(LinuxNativeUtils.java:64)
[2008-02-20 10:53:01.507]:     	at org.netbeans.installer.utils.system.NativeUtils.getInstance(NativeUtils.java:93)
[2008-02-20 10:53:01.507]:     	at org.netbeans.installer.utils.SystemUtils.getNativeUtils(SystemUtils.java:1063)
[2008-02-20 10:53:01.508]:     	at
org.netbeans.installer.utils.SystemUtils.getDefaultApplicationsLocation(SystemUtils.java:326)
[2008-02-20 10:53:01.508]:     	at org.netbeans.installer.utils.SystemUtils.resolveString(SystemUtils.java:124)
[2008-02-20 10:53:01.509]:     	at
org.netbeans.installer.wizard.components.WizardComponent.resolveString(WizardComponent.java:342)
[2008-02-20 10:53:01.509]:     	at
org.netbeans.installer.wizard.components.WizardComponent.getProperty(WizardComponent.java:305)
[2008-02-20 10:53:01.509]:     	at
org.netbeans.installer.wizard.components.WizardComponent.getProperty(WizardComponent.java:290)
[2008-02-20 10:53:01.510]:     	at
org.netbeans.installer.wizard.components.actions.netbeans.NbInitializationAction.execute(NbInitializationAction.java:80)
[2008-02-20 10:53:01.510]:     	at org.netbeans.installer.wizard.components.WizardAction$1.run(WizardAction.java:120)
[2008-02-20 10:53:08]> ... java process finished with code 130
[2008-02-20 10:53:08]> Removing directory /tmp/.nbi-3025246.tmp
[2008-02-20 10:53:08]> exitCode = 130

so, from what I understand, this installer only work in i386 processors since the shipped linux.so is not valid on this
platform.

Am I right? Will you support this platform again (as it was with nb 5.0)?

Thanks,
Giuseppe
Comment 1 dlipin 2008-02-20 11:24:18 UTC
Currently Linux PPC is not a supported platform for NetBeans IDE Installer (only x86 and x86_64).
Unfortunately there are no real plans to add Linux PPC support in the nearest future.

As the workaround you can use NetBeans from zip distribution or from Ubuntu packages (if you have ubuntu).
Comment 2 eppesuigoccas 2008-02-20 11:43:26 UTC
Thanks for your quick reply.
I found the "correct" version to download a few minutes after reporting this bug. It seems it is working well, but the
import settings from 5.0.

What do I "misses" using the platform independent version? I see a major difference compared to x86 version: I cannot
use the system (gnome) look and feel. Is this related to the "independent version" or to the IBM java VM?

Thanks again,
Giuseppe
Comment 3 dlipin 2008-02-20 12:08:41 UTC
Giuseppe,
> I found the "correct" version to download a few minutes after reporting this bug. It seems it is working well, but the
> import settings from 5.0.
you mean that you were not offered to import settings from NetBeans 5.0? do you use default userdirs?

> What do I "misses" using the platform independent version? 
Actually there are no runtimes in platform independent version like GlassFish, Tomcat, OpenESB (related to SOA 
functionality) and WTK (Java ME emulator).

> I see a major difference compared to x86 version: I cannot use the system (gnome) look and feel. Is this related to 
the "independent version" or to the IBM java VM?
I do think that it is related to IBM Java VM. There is a number of known issues with using NetBeans on IBM`s Java (both 
Java5 and Java6). Unfortunately I don`t know the exact number of those issue or even the overall summary.

Giuseppe, feel free to file any issues and difficulties, that you experience while using NetBeans 6 on IBM`s Java 
against 'ide' component, 'code' subcomponent.


Reopening for future tracking... hopefully one day we`ll have Linux/PowerPC support as well.
(See also Issue 127851 that is related to Linux/PPC support in NetBeans C++ modules)
Comment 4 eppesuigoccas 2008-02-20 12:23:51 UTC
I opened a different report for the problem related to "import settings" panel
http://www.netbeans.org/issues/show_bug.cgi?id=127830
and a second report (exception?) related to an exception I always get when netbeans starts up.
This second report has been automatically sent via netbeans but I cannot find it on netbeans.org. The problems is that I
always get this exception:

INFO [org.netbeans.core.ui.warmup.DiagnosticTask]
java.lang.NoSuchMethodException: com.ibm.lang.management.OperatingSystemMXBeanImpl.getTotalPhysicalMemorySize()
        at java.lang.Class.throwNoSuchMethodException(Class.java:280)
        at java.lang.Class.getMethod(Class.java:805)
[catch] at org.netbeans.core.ui.warmup.DiagnosticTask.logEnv(DiagnosticTask.java:82)
        at org.netbeans.core.ui.warmup.DiagnosticTask.run(DiagnosticTask.java:74)
        at org.netbeans.core.WarmUpSupport.run(WarmUpSupport.java:100)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)
Comment 5 dlipin 2008-02-20 13:20:28 UTC
Giuseppe,

I guess that this NoSuchMethodException should be reported against core/ui.
Please attach full messages.log in that issue (if you file it :)) 
Please add the following info there:
Does it reproducible with fresh userdir (delete ~/.netbeans/6.0) ? 
Does it reproducible with development builds of NetBeans (http://bits.netbeans.org/download/trunk/nightly/latest)?
Comment 6 dlipin 2008-05-06 15:29:26 UTC
Fixed.
http://hg.netbeans.org/main/rev/cf3a05d80a92

Now NetBeans installer can hopefully run on Linux PowerPC (both ppc and ppc64).
Comment 7 Quality Engineering 2008-05-07 04:50:17 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #180 build
Changeset: http://hg.netbeans.org/main/rev/cf3a05d80a92
User: Dmitry Lipin <dlipin@netbeans.org>
Log: Issue #127826 Add support for Linux/PPC systems


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo