Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 127176 - Exception breaks code completion, etc.
Exception breaks code completion, etc.
Status: RESOLVED DUPLICATE of bug 126135
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jesse Glick
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-12 02:22 UTC by _ tboudreau
Modified: 2008-02-13 10:56 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2008-02-12 02:22:07 UTC
I'm getting the following with some projects from a vanilla checkout of NetBeans, using 6.0 release.  Note there is no such directory as /Users/tim/nbsrc/core

This seems to break source indexing, breaking fix imports, causing lots of nonsense error markers in sources, etc.

java.io.IOException: Not an NBM project in /Users/tim/nbsrc/core
	at org.netbeans.modules.apisupport.project.universe.ModuleList$1.run(ModuleList.java:161)
	at org.netbeans.modules.apisupport.project.universe.ModuleList$1.run(ModuleList.java:153)
	at org.openide.util.Mutex.readAccess(Mutex.java:291)
	at org.netbeans.modules.apisupport.project.universe.ModuleList.getModuleList(ModuleList.java:152)
	at org.netbeans.modules.apisupport.project.universe.ModuleList.getModuleList(ModuleList.java:136)
	at org.netbeans.modules.apisupport.project.universe.TestEntry.getNetBeansOrgPath(TestEntry.java:187)
	at org.netbeans.modules.apisupport.project.universe.TestEntry.getSrcDir(TestEntry.java:139)
	at org.netbeans.modules.apisupport.project.queries.GlobalSourceForBinaryImpl.findSourceRoots(GlobalSourceForBinaryImpl.java:106)
Caused: java.lang.AssertionError
	at org.netbeans.modules.apisupport.project.queries.GlobalSourceForBinaryImpl.findSourceRoots(GlobalSourceForBinaryImpl.java:148)
	at org.netbeans.api.java.queries.SourceForBinaryQuery.findSourceRoots(SourceForBinaryQuery.java:89)
	at org.netbeans.modules.java.source.classpath.GlobalSourcePath.createResources(GlobalSourcePath.java:302)
	at org.netbeans.modules.java.source.classpath.GlobalSourcePath.access$2200(GlobalSourcePath.java:96)
	at org.netbeans.modules.java.source.classpath.GlobalSourcePath$SourcePathImplementation.getResources(GlobalSourcePath.java:596)
	at org.netbeans.api.java.classpath.ClassPath$SPIListener.propertyChange(ClassPath.java:902)
	at org.openide.util.WeakListenerImpl$PropertyChange.propertyChange(WeakListenerImpl.java:186)
	at org.netbeans.modules.java.source.classpath.GlobalSourcePath$SourcePathImplementation.firePropertyChange(GlobalSourcePath.java:645)
	at org.netbeans.modules.java.source.classpath.GlobalSourcePath$1.run(GlobalSourcePath.java:233)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)
Comment 1 Lukas Hasik 2008-02-13 10:56:08 UTC
Tim, patch that solves the problem is attached to the duplicate issue

*** This issue has been marked as a duplicate of 126135 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo