Bug 127085 - I18N - run using command line not show multibyte ok if project encoding property is not utf-8
I18N - run using command line not show multibyte ok if project encoding prope...
Status: RESOLVED DUPLICATE of bug 127088
Product: php
Classification: Unclassified
Component: Project
6.x
Sun All
: P2 (vote)
: TBD
Assigned To: rmatous
issues@php
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-11 04:22 UTC by Ken Frank
Modified: 2008-06-23 16:10 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2008-02-11 04:22:02 UTC
running nb in ja locale on solaris or windows.

1. create php project whose encoding property is not utf-8.
have multibyte be in php program in an echo statement - the mbyte
is in the encoding of the project encoding.

run in command line - the multibyte does not
show ok in output window


2. do same steps, but have a different project (do not change the same 
one) to have project encoding of euc-jp for solaris or win31j for windows.
these encodings are the default encodings for the ja locale.

the multibyte does show ok in output window.

3. user can use any project encoding and the php project should use it; it might
not be the default utf-8 one.

also, if html file is created to run the php, perhaps it needs meta charset tag
although its seen that run php file in browser, in which php is made into a html file,
even with meta charset tag, the non ascii does not show well in certain situations, but that
is topic for another issue.
Comment 1 Ken Frank 2008-02-11 04:23:41 UTC
NOTE - for this issues, its assumed php project name and path to that project
are ascii only; using non ascii in these is topic of another issue.

ken.frank@sun.com
Comment 2 rmatous 2008-06-23 16:10:39 UTC
Probably duplicate of #127088 (definitely have much in common). 

*** This issue has been marked as a duplicate of 127088 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo