Bug 127007 - Should have a way to specify what's in an update
Should have a way to specify what's in an update
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Tulach
au-issues
: API
: 129898 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-08 16:41 UTC by tomwheeler
Modified: 2010-12-08 13:26 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tomwheeler 2008-02-08 16:41:42 UTC
I don't know whether this would be addressed in autoupdate, module system or API support, but hopefully I will give
enough information that you can reassign if needed.

We are using an AutoUpdate Center for our application.  Our users have complained that while they really like this
feature, there is no way for them to know what is in an update when we make one available.  The plugin manager simply
shows the information about the module and not specifically about the update.  There is currently no place to enter this
information, except for hacking it by appending information about each update to the OpenIDE-Module-Long-Description field.

I feel there should be an additional, but optional, field (or fields) that allows the developer to specify what specific
issues have been fixed by this update.  The plugin manager should show this information so the user can determine
whether or not to install the update.  

The operating system update managers for Windows, Mac OS X and Ubuntu Linux already work as I have described.
Comment 1 Jiri Rechtacek 2008-10-17 07:34:50 UTC
Need to add new attribute into Update Center Descriptor DTD and also new getter on SPI/API
Comment 2 Antonin Nebuzelsky 2008-11-14 15:31:55 UTC
Reassigning to the new "autoupdate/*" owner dlipin.
Comment 3 dlipin 2009-05-12 17:11:52 UTC
*** Issue 129898 has been marked as a duplicate of this issue. ***
Comment 4 Jaroslav Tulach 2010-11-23 12:24:07 UTC
I can accept a patch. If none is provided, I close as won'tfix, until someone who really cares about the feature shows up.
Comment 5 Jaroslav Tulach 2010-12-08 13:26:28 UTC
At least propose changes to catalog.xml, meanwhile won'tfix.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo