Bug 126989 - [65cat] There is no way to save the downloaded modules
[65cat] There is no way to save the downloaded modules
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jaroslav Tulach
au-issues
: REGRESSION
: 88243 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-08 11:50 UTC by Michel Graciano
Modified: 2010-10-07 18:49 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2008-02-08 11:50:22 UTC
There is no way to save the downloaded nbm files on new plugin manager as before. I miss this feature.
Comment 1 Jiri Rechtacek 2008-02-08 12:34:18 UTC
Autoupdate since NB6.0 is based on new concept than NB3.3 Autoupdate. Save NBM file is some of features which are not
supported anymore. On other side, Autoupdate 6.0 brings API, you can build a plugin built on the top the API with this
feature. We can track is a new feature of Plugin Manger in future.
Comment 2 Jiri Rechtacek 2008-02-08 12:38:48 UTC
Btw. the feature was evaluated at http://wiki.netbeans.org/OfflineMode
Comment 3 Michel Graciano 2008-02-08 12:44:51 UTC
IMO, it is not a feature, since it is a regression from previous version. Any regression, following the guidelines, is a P1.
About the wiki, I liked the propose and the question is... any idea about when it will be available?

Regards
Comment 4 Jiri Rechtacek 2008-10-16 17:27:47 UTC
*** Issue 88243 has been marked as a duplicate of this issue. ***
Comment 5 Antonin Nebuzelsky 2008-11-14 15:33:11 UTC
Reassigning to the new "autoupdate/*" owner dlipin.
Comment 6 Jaroslav Tulach 2010-10-07 18:23:48 UTC
Michel, are you still missing this feature? Do you want to help implementing it?
Comment 7 Michel Graciano 2010-10-07 18:49:07 UTC
I really would enjoy this feature if possible and this time I usually download manually the necessary modules. Personally speaking I think this is a important feature missing in the IDE and there is a workaround which is download it directly from the website but it is not really easy, mainly for people which don't know how to read a update.xml file. I really would like to help to implement it if you could point me where should/could I start :)
I have no much time now but as soon as possible I can start it and send a patch if you don't mind.

Thanks


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo