Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 126828 - Replace password with some text
Replace password with some text
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P2 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
:
: 127406 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 12:16 UTC by novakm
Modified: 2008-02-14 16:03 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Propsed patch (8.18 KB, text/plain)
2008-02-06 19:26 UTC, John Rice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description novakm 2008-02-06 12:16:58 UTC
It would be nice if real password would not be displayed in output tab or elsewhere. There could be *** instead as they
are now for the second line when pushing to default for instance.
Comment 1 John Rice 2008-02-06 19:26:34 UTC
Created attachment 56193 [details]
Propsed patch
Comment 2 John Rice 2008-02-06 19:28:39 UTC
Mercurial Push
--------------
INFO Changesets to push:
comparing with https://jrice:****@hg.netbeans.org/main
searching for changes
changeset:   66222:fb1e677f1dcf
tag:         tip
user:        jrice@netbeans.org
date:        Wed Feb 06 19:17:27 2008 +0000
files:       mercurial/src/org/netbeans/modules/mercurial/ui/pull/FetchAction.java
mercurial/src/org/netbeans/modules/mercurial/ui/pull/PullAction.java
mercurial/src/org/netbeans/modules/mercurial/ui/push/PushAction.java
mercurial/src/org/netbeans/modules/mercurial/util/HgCommand.java
mercurial/src/org/netbeans/modules/mercurial/util/HgUtils.java
description:
#126828: replace password text in push and pull paths and in error output with ****

pushing to https://jrice:****@hg.netbeans.org/main
searching for changes
adding changesets
adding manifests
adding file changes
added 1 changesets with 5 changes to 5 files
notify: sending 1 subscribers 1 changes
INFO Push To: https://jrice:****@hg.netbeans.org/main
INFO From:    /export/home/jr140578/work/main_in
INFO: End of Mercurial Push
Comment 3 Padraig Obriain 2008-02-14 16:03:45 UTC
*** Issue 127406 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo