Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 126602 - Cannot rerun netbeans plug-in
Cannot rerun netbeans plug-in
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@apisupport
:
: 127177 127205 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-04 11:02 UTC by soldatov
Modified: 2008-02-19 16:49 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
log (9.22 KB, text/plain)
2008-02-04 11:03 UTC, soldatov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2008-02-04 11:02:22 UTC
I installed full Netbeans nightly build (with all packs). And I have such problem:
1)create new netbeans plug in module project (standalone, with default settings)
2)run it (F6)
3)close the appeared IDE
4)run it again
==> exceptions
Comment 1 soldatov 2008-02-04 11:03:43 UTC
Created attachment 55983 [details]
log
Comment 2 Lukas Hasik 2008-02-04 12:48:59 UTC
seems as wrong project setting -> passing to apisupport for evaluation
Comment 3 Petr Nejedly 2008-02-04 13:12:47 UTC
No, not really. More probably a problem with module system caches.
Comment 4 Jaroslav Tulach 2008-02-05 08:37:47 UTC
Nejedlák is probably right.
Comment 5 Jesse Glick 2008-02-05 19:55:55 UTC
A duplicate, I believe.
Comment 6 Jaroslav Tulach 2008-02-11 15:36:01 UTC
Reproduced.
Comment 7 Jaroslav Tulach 2008-02-11 15:57:09 UTC
Nejedláku, I believe this is a bug in your code. If one uses testing modules, then 

      Source _src = Source.sources.get(jar);

in JarClassLoader can yield null. Is that a bug, do how would you fix it?
Comment 8 Petr Nejedly 2008-02-11 17:41:40 UTC
If I understand it correctly, the subsequent start (or is it reload inside an already running IDE) uses some kind of
cached URL to a file which is either no longer there, or whose class loader was destroyed.
Either way, the system should claim that there's no such resource.

It might have claimed that the resource exists (i.e. getResource returned well-formed URL into (nonexistent) jar)
because the cache have contained an entry for given file (it was there on the first start).
I would probably disable the cache if there are testing modules somehow.
Comment 9 Jaroslav Tulach 2008-02-12 20:01:53 UTC
*** Issue 127205 has been marked as a duplicate of this issue. ***
Comment 10 Lukas Hasik 2008-02-13 10:05:10 UTC
*** Issue 127177 has been marked as a duplicate of this issue. ***
Comment 11 Jaroslav Tulach 2008-02-13 15:31:04 UTC
changeset:   66879:ab0ad4db9142
tag:         tip
user:        Jaroslav Tulach <jtulach@netbeans.org>
date:        Wed Feb 13 16:30:29 2008 +0100
summary:     #126602: Try to survive wrong cached data by disabling further caching and continuing
Comment 12 Jiri Skrivanek 2008-02-19 10:06:28 UTC
Exception is fixed but module is loaded just once and it is not reloaded anymore. To reproduce:

- create new netbeans plug in module project (standalone, with default settings)
- add some action to main menu
- run module (F6)
- check action is there
- add one more action to main menu
- run module (F6) but the second action doesn't appear in main menu. It behaves similarly if you call 'Reload in
Development IDE'.

Product Version: NetBeans IDE Dev (Build 20080219071336)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)

Comment 13 Jaroslav Tulach 2008-02-19 16:49:31 UTC
68135:865399018b73


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo