Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 126454 - Reporting File Systems warning
Reporting File Systems warning
Status: RESOLVED DUPLICATE of bug 125720
Product: platform
Classification: Unclassified
Component: Filesystems
6.x
All Windows XP
: P3 (vote)
: 6.x
Assigned To: rmatous
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-31 20:05 UTC by _ krystyna
Modified: 2008-12-22 11:02 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ krystyna 2008-01-31 20:05:17 UTC
NetBeans IDE Dev (Build 200801311204)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1


WARNING: externally deleted file: C:/Documents and Settings/Krystyna Polomski/My 
Documents/NetBeansProjects/WebApplication872/build/web/Page1.jsp  - please report. (For additional information see: 
http://wiki.netbeans.org/wiki/view/FileSystems)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.printWarning
(FileObjectFactory.java:172)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.checkCacheState
(FileObjectFactory.java:153)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.checkCacheState
(FileObjectFactory.java:143)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.issueIfExist
(FileObjectFactory.java:235)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.findFileObject
(FileObjectFactory.java:139)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.findFileObject
(FileObjectFactory.java:116)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.findFileObject
(FileObjectFactory.java:111)
        at org.netbeans.modules.masterfs.filebasedfs.FileBasedURLMapper.getFileObjects(FileBasedURLMapper.java:138)
        at org.netbeans.modules.masterfs.MasterURLMapper.getFileObjects(MasterURLMapper.java:61)
        at org.openide.filesystems.URLMapper.findFileObject(URLMapper.java:210)
        at org.openide.filesystems.FileUtil.toFileObject(FileUtil.java:617)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.LockForFile.releaseLock(LockForFile.java:276)
        at org.openide.filesystems.FileLock.finalize(FileLock.java:125)
        at java.lang.ref.Finalizer.invokeFinalizeMethod(Native Method)
        at java.lang.ref.Finalizer.runFinalizer(Finalizer.java:83)
        at java.lang.ref.Finalizer.access$100(Finalizer.java:14)
        at java.lang.ref.Finalizer$FinalizerThread.run(Finalizer.java:160)
java.lang.Exception: C:\Documents and Settings\Krystyna Polomski\My Documents\NetBeansProjects\WebApplication872
\build\web\Page1.jsp
        at org.netbeans.TopSecurityManager.prepareForWarning(TopSecurityManager.java:297)
        at org.netbeans.TopSecurityManager.checkDelete(TopSecurityManager.java:283)
        at java.io.File.delete(File.java:902)
        at org.apache.tools.ant.taskdefs.Delete.delete(Delete.java:637)
        at org.apache.tools.ant.taskdefs.Delete.removeDir(Delete.java:678)
        at org.apache.tools.ant.taskdefs.Delete.removeDir(Delete.java:675)
        at org.apache.tools.ant.taskdefs.Delete.execute(Delete.java:543)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
        at sun.reflect.GeneratedMethodAccessor177.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.Target.execute(Target.java:357)
        at org.apache.tools.ant.Target.performTasks(Target.java:385)
        at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
        at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
        at org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:277)
        at org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:460)
        at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:151)
Comment 1 Peter Pis 2008-02-01 14:19:18 UTC
Reassigning to "openide".
Comment 2 Lukas Hasik 2008-02-01 14:28:33 UTC
already reported
thank you for report

*** This issue has been marked as a duplicate of 125720 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo