Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 126260 - Editor loses keyboard input in several scenarios
Editor loses keyboard input in several scenarios
Status: RESOLVED DUPLICATE of bug 119617
Product: editor
Classification: Unclassified
Component: Settings
6.x
All All
: P2 with 1 vote (vote)
: 6.x
Assigned To: issues@editor
issues@editor
:
: 126563 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-30 10:42 UTC by m0thr4
Modified: 2015-12-29 06:55 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
uigestures file from Netbeans 6 (95.43 KB, text/plain)
2008-02-15 08:51 UTC, m0thr4
Details
nOtEXT (97.23 KB, patch)
2014-08-24 03:32 UTC, ANKURDECAPRIO
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description m0thr4 2008-01-30 10:42:29 UTC
Problem:  Cannot edit code with keyboard, yet all right-click mouse actions still work (such as copy, cut, paste, fix
imports etc), so code can still be modified.

To repoduce: (using Netbeans 6.0 either Ubuntu Linux or OS X), do any of the following:

* Create a new file.  New file appears, but cannot type anything in it. (happens consistently)
* Open template in Template Manager (happens consistently)
* Right-click and select "fix imports" (doesn't always reproduce the problem)
* Open any file (occasionaly reproduces the problem)

To fix:

Close and re-open the file.  Sometimes you need to do this several times; other times, you need to quit and relauncch
Netbeans.  This fix only works with project files: for example, I have not yet been able to edit any of the template
files in Netbeans 6.0 with my keyboard.
Comment 1 guigouz 2008-02-05 18:28:35 UTC
Seems related to 125255.
Keyboard stops responding here (OS X 10.4) when netbeans adds some code to the file (like when adding an import or
generating getters/setters). If I open a modal dialog (for example, the file open dialog) and close it, it starts
working again.
Comment 2 Vitezslav Stejskal 2008-02-06 10:55:29 UTC
Most likely settings related. There have been fixes in this area for 6.1. I tried the steps you mentioned in your first
post and all seemed to work. Could you please try again with latest dev build or 6.1M1 and reopen if the problem still
persists? Thanks
Comment 3 Vitezslav Stejskal 2008-02-06 11:02:09 UTC
*** Issue 126563 has been marked as a duplicate of this issue. ***
Comment 4 Vitezslav Stejskal 2008-02-06 13:30:52 UTC
Sorry, forgot to mark it fixed.
Comment 5 m0thr4 2008-02-07 08:24:54 UTC
I get exactly the same problems with Netbeans 6.1M on Ubuntu.
Comment 6 Jiri Prox 2008-02-07 08:40:26 UTC
Which window manager do you use?
Comment 7 m0thr4 2008-02-07 09:15:08 UTC
I am using Metacity (the default window manager for Ubuntu).
Comment 8 Vitezslav Stejskal 2008-02-08 11:39:10 UTC
Umm, I just downloaded and tried 6.1M1 and all seems to work normally. I'm on Ubuntu 7.10 with metacity.

Product Version: NetBeans IDE Dev (Build 200801280931)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: Linux version 2.6.22-14-generic running on i386; UTF-8; en_US (nb)

When this happens can you see the caret in the editor window? What shortcuts exactly are broken? Can you type normal
text (ie. latin characters, numbers, etc)? Are you using vanilla 6.1M1 with fresh userdir? What JDK? Thanks
Comment 9 m0thr4 2008-02-08 13:23:10 UTC
> When this happens can you see the caret in the editor window? 
Yes, and I can select any area of text and cut, copy, paste, format code, fix imports etc. with a right click of the mouse (or by selecting options from the 
drop-down menu.

> What shortcuts exactly are broken? 
None, unless you're talking about keyboard shortcuts... in which case, all of them as the keyboard stops working.

>Can you type normal
text (ie. latin characters, numbers, etc)? 
Not into the files that are affected by this problem.

>Are you using vanilla 6.1M1 with fresh userdir? What JDK? Thanks
A fresh user directory is the only thing I haven't tried (I don't want to reinstall Ubuntu if possible).  I will try that and report back.
Comment 10 Vitezslav Stejskal 2008-02-08 14:49:13 UTC
> I don't want to reinstall Ubuntu if possible

No, please don't do that. I don't think this would help and if other apps run normally it's likely to be Netbeans issue.
Using fresh userdir might or might not help depending on what the problem is. But if you are saying that reopening the
affected file helps (or restarting Netbeans) than fresh userdir is probably not going to help either.

A few more questions: When this happens does the keyboard work in other parts of the IDE (ie. try renaming a node in
projects or type somewhere in Tools-Options -> Editor -> Code Templates, etc) or maybe even in other edited files? What
do the arrow keys do? Do they move the caret or scroll the editor window? Next time when it happens could you please
close the IDE immediately and attach your <userdir>/var/log/uigestures file here? Thanks
Comment 11 Max Sauer 2008-02-14 15:02:22 UTC
One more question -- do you have compiz/beryl enabled?

This is a possible duplicate if issue 119617.
Comment 12 m0thr4 2008-02-15 08:49:17 UTC
> A few more questions: When this happens does the keyboard work in other parts of the IDE (ie. try renaming a node in
> projects or type somewhere in Tools-Options -> Editor -> Code Templates, etc) or maybe even in other edited files? 

I can still use the keyboard to type in a popup window (e.g. if I refactor the name of new java class I have just
created).  I can also type in Tools-Options -> Editor -> Code Templates.  But when I go back to my new file, I still
can't type in it until I close and re-open it

>What do the arrow keys do? Do they move the caret or scroll the editor window? 
No - none of the keys on the keyboard have any effect at all, including the arrow keys.


> Next time when it happens could you please
> close the IDE immediately and attach your <userdir>/var/log/uigestures file here? Thanks
Of course - see attached file.
Comment 13 m0thr4 2008-02-15 08:51:27 UTC
Created attachment 56714 [details]
uigestures file from Netbeans 6
Comment 14 m0thr4 2008-02-15 08:58:16 UTC
> One more question -- do you have compiz/beryl enabled?
I have tried with and without compiz - it doesn't seem to make a difference to the problem.


> This is a possible duplicate if issue 119617.
Yes, I had this problem in Netbeans 5.5 both on Linux and on my Mac, although since I have moved to Java SE 6, I haven't
been able to use the Mac, so I can't comment on how Netbeans 6 performs there.
Comment 15 Vitezslav Stejskal 2008-02-15 11:27:20 UTC
Thanks for the gestures file. Surprisingly it only contains several actions, which all seem harmless AFAICT.

org.netbeans.modules.autoupdate.ui.actions.PluginManagerAction - plugins manager
org.netbeans.modules.project.ui.actions.OpenProject - projects open dialog
org.codehaus.mevenide.netbeans.NbMavenProject - 1 maven project was opened
org.netbeans.modules.refactoring.spi.impl.RenameAction - that's where you were testing the keyboard input right
org.netbeans.modules.options.OptionsWindowAction - Tools-Options, the same as above

Ehm, I'm still not sure what the problem is. I'm writing a little module for purpose of tracking down #119617, which
will dump status information about all open editors. I'll post a link here to when it's ready. It would be great if you
could install it and send us back its output. The tricky part is that we don't know what to look for so it's likely to
take several iterations. It's probably worthless mentioning that any ideas are more than welcome. Thanks
Comment 16 Miloslav Metelka 2008-02-15 14:38:44 UTC
I've done a research of calling public methods of java.awt.Component, Container and javax.swing.JComponent outside of an
AWT thread. There are number of catches and I'll attempt to eliminate them progressively.
Comment 17 rvalyi 2008-02-15 18:26:34 UTC
Guys, as msauer suggested,

issue http://www.netbeans.org/issues/show_bug.cgi?id=126260
Is a perfect description of my problem too (including whole discussion). I guess both are duplicates indeed unless I
missed something very subtle.

Hope this helps.

Raphaël Valyi.
Comment 18 rvalyi 2008-02-15 18:28:58 UTC
sorry, I posted in the wrong one, I actually wanted to say
this bug seems indeed a duplicate of http://www.netbeans.org/issues/show_bug.cgi?id=119617

Raphaël Valyi.
Comment 19 Vitezslav Stejskal 2008-02-18 11:04:33 UTC
Ok, so if everyone agrees I making this a duplicate of issue #119617.

*** This issue has been marked as a duplicate of 119617 ***
Comment 20 ANKURDECAPRIO 2014-08-24 03:32:01 UTC
Created attachment 148863 [details]
nOtEXT

HJH
Comment 21 NoBugs 2015-08-26 06:57:33 UTC
By "loses keyboard input" do you mean if you type a word it types all of it except for one letter in the middle, seemingly randomly? If so I have had this sooo many times on my 14.04 with Netbeans 8.0.2. Any chance it will be fixed for 8.1?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo