Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 126160 - jnlp build does not complete due to href problem
jnlp build does not complete due to href problem
Status: VERIFIED FIXED
Product: apisupport
Classification: Unclassified
Component: Harness
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Jesse Glick
issues@apisupport
release601_fixes_candidate1 release60...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-29 01:15 UTC by Ken Frank
Modified: 2008-02-20 18:17 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
message (656 bytes, text/plain)
2008-01-29 01:17 UTC, Ken Frank
Details
Replacement for harness/tasks.jar including patch (412.65 KB, application/octet-stream)
2008-01-29 01:59 UTC, Jesse Glick
Details
message (1.97 KB, text/plain)
2008-01-29 06:41 UTC, Ken Frank
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2008-01-29 01:15:48 UTC
this is related to 125790, there is a fix for it, but when running the
tasks.jar with the fix, there is another error and the build does not complete.

I'm in ja locale using nb6.0.1 ml build.

see 125790 for other details on how to replicate the issue.

see attachment for the error message related to this.

am making this p1
Comment 1 Ken Frank 2008-01-29 01:17:06 UTC
Created attachment 55685 [details]
message
Comment 2 Jesse Glick 2008-01-29 01:58:33 UTC
Fixed in 9b75dacad28e, I guess. (Cannot personally verify.)
Comment 3 Jesse Glick 2008-01-29 01:59:24 UTC
Created attachment 55687 [details]
Replacement for harness/tasks.jar including patch
Comment 4 Ken Frank 2008-01-29 06:40:56 UTC
error msg using this patch is at end of the attached - looks like its not finding
some other jar files.

ken.frank@sun.com
Comment 5 Ken Frank 2008-01-29 06:41:26 UTC
Created attachment 55690 [details]
message
Comment 6 Jesse Glick 2008-01-29 16:08:03 UTC
Don't know, maybe some other bug? The file name it is looking for is now correct, unlike before. I currently have no way
of trying to reproduce any problems on Windows, much less a ML build, so I cannot say for sure. Try filing a separate
issue, CC me, and see if jtulach has any time to look at it, as he was I think the original author of this task (we have
both worked on it at various times).
Comment 7 Lukas Hasik 2008-01-30 15:28:01 UTC
works for me with 601 with the latest patch on windows in EN locale. It didn't worked with 6.0.1

Created dir: C:\Documents and Settings\Lukas\My Documents\NetBeansProjects\601\PaintApp\dist
Building war: C:\Documents and Settings\Lukas\My Documents\NetBeansProjects\601\PaintApp\dist\paintit.war
BUILD SUCCESSFUL (total time: 1 minute 0 seconds)

Ken, can you verify in the other locale? thanks
Comment 8 Ken Frank 2008-01-30 16:39:14 UTC
I regot the tasks.jar and reinstalled it; it does work now
in ja locale, xp, 601 ml build.

ken.frank@sun.com
Comment 9 Marian Mirilovic 2008-01-30 17:03:16 UTC
marking verified based on lhasik's & kfrank's comments
Comment 10 Karthikeyan Rajeswaran 2008-02-11 21:05:23 UTC
The fix has been ported into the release601_fixes branch.

Checking in antsrc/org/netbeans/nbbuild/MakeJNLP.java;
/cvs/nbbuild/antsrc/org/netbeans/nbbuild/Attic/MakeJNLP.java,v  <--  MakeJNLP.java
new revision: 1.27.12.1; previous revision: 1.27
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo