Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 126124 - Ignore command not available on folders
Ignore command not available on folders
Status: RESOLVED DUPLICATE of bug 157729
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-28 16:28 UTC by _ tboudreau
Modified: 2009-11-02 13:37 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2008-01-28 16:28:52 UTC
I notice that the Ignore menu item is always disabled on folders;  this is very troublesome if you want to exclude build directories from your repository.  
Wouldn't be hard to generate a pattern to match whatever folder it is...
Comment 1 John Rice 2008-02-09 18:00:23 UTC
Its simple to add the Ignore support for directories, the issue is how mercurial reports status for files contained in
these ignored dirs, it should report them as ignored but is not:
http://www.selenic.com/mercurial/bts/issue886

When this is fixed in mercurial we can simplify a lot of the hacks we've had to put in to work around these Ignore
issues [ignored files are being returned for instance from an ignored directory so on large ignored dirs we got a huge
performance hit and hhad to resort to parsing the .hgignore ourselves, though this is far from ideal].
Comment 2 jonast 2008-10-30 19:56:27 UTC
http://www.selenic.com/mercurial/bts/issue886
This issue has now been fixed for a long time, does this mean that it can be resolved in netbeans aswell?
Comment 3 Ondrej Vrabec 2009-11-02 13:37:51 UTC

*** This issue has been marked as a duplicate of 157729 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo