Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 126062 - Cannot rename a file which is not yet added to a repository
Cannot rename a file which is not yet added to a repository
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-28 02:30 UTC by _ tboudreau
Modified: 2008-01-31 11:26 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
proposed patch (3.34 KB, patch)
2008-01-30 13:23 UTC, Padraig Obriain
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2008-01-28 02:30:51 UTC
I have some project folders in a private mercurial repository that were moved there from nb.org's contrib project.  Mercurial knows nothing about them yet.  
I am trying to rename some of them.

When I try to rename one of these folders in the IDE I get:
ERROR Command failed:
Command: [/usr/local/bin/hg, rename, --repository, /Users/tim/space/hg_nb/nb_all/ext, --cwd, /Users/tim/space/hg_nb/nb_all/ext, 
dynactions_1.nodes, api.dynactions.nodes]
Output: [abort: no files to copy]
in the output window.

The module should detect if the files are known to mercurial and do a normal rename on them if not.
Comment 1 Padraig Obriain 2008-01-30 11:24:45 UTC
Can you clarify whether the problem is with files or folders?
Comment 2 _ tboudreau 2008-01-30 11:40:28 UTC
This was folders;  I filed a similar issue for renaming files.  May be the same thing.
Comment 3 Padraig Obriain 2008-01-30 11:50:29 UTC
I can reproduce it in Favourites or Files View but not in Projects View.

I do not see an issue open about renaming files. What is its number?
Comment 4 Padraig Obriain 2008-01-30 13:23:57 UTC
Created attachment 55763 [details]
proposed patch
Comment 5 Padraig Obriain 2008-01-30 13:26:35 UTC
searching for changes
changeset:   65117:5c95b41895b9
user:        padraigob@netbeans.org
date:        Wed Jan 30 13:21:35 2008 +0000
files:       mercurial/src/org/netbeans/modules/mercurial/MercurialInterceptor.java
mercurial/src/org/netbeans/modules/mercurial/util/HgCommand.java
description:
Issue 126062: Allow rename of directory to work even if it is does not contain managed files.


changeset:   65156:9b02794858a0
tag:         tip
parent:      65117:5c95b41895b9
parent:      65155:6c7b13ce6dd0
user:        padraigob@netbeans.org
date:        Wed Jan 30 13:25:24 2008 +0000
description:
Automated merge with http://hg.netbeans.org/main


Comment 6 _ tboudreau 2008-01-30 19:13:09 UTC
Hrm, I thought I filed it.

Just copy a Foo.java (managed) and paste it as Foo_1.java (unmanaged).  Refactor-rename it to Bar.java.  The content is refactored;  the filename is not 
changed.
Comment 7 Padraig Obriain 2008-01-31 11:26:59 UTC
I cannot reproduce this new problem from the description you have given. Please open a new bug for this.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo