Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 125999 - RES: Icons for Actions should not be defined with full path in prop
RES: Icons for Actions should not be defined with full path in prop
Status: RESOLVED DUPLICATE of bug 106831
Product: guibuilder
Classification: Unclassified
Component: App Framework
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-25 12:30 UTC by Jana Maleckova
Modified: 2008-02-05 14:37 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jana Maleckova 2008-01-25 12:30:52 UTC
Product Version: NetBeans IDE Dev (Build 200801241217)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)

Description:
============
Icons set for actions in JDA projects are defined in appropriate property file with full path. And this causes runtime
error when package is renamed. Origin path is not changed (adapted) to new name of package
Have JDA project
1. create new action with assigned icon
2. build project
3. rename main package
4. build &clean project
5. run it
resource exception in output win.
Comment 1 Jan Stola 2008-02-05 14:37:18 UTC
This is one of unsupported scenarios. See http://wiki.netbeans.org/GUIBuilderRefactoring#section-GUIBuilderRefactoring-
ResourcesRefactoring

*** This issue has been marked as a duplicate of 106831 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo