Status: RESOLVED FIXED
Product: web
Classification: Unclassified
Component: HTML Editor
6.x
Sun All
: P2 (vote)
: 6.x
Assigned To: Marek Fukala
Jindrich Sedek
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-25 09:42 UTC by Kenji Tachibana
Modified: 2009-05-18 10:47 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
image (113.74 KB, image/jpeg)
2008-01-28 17:31 UTC, kaa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kenji Tachibana 2008-01-25 09:42:19 UTC
Following UI messages on JSP editor does not localized.

(Right Click) -> Code Folds 
        -> Expand Scriptlet
        -> Collapse Scriptlet
        -> Expand HTML tag
        -> Collapse HTML tag
        -> Expand JSP Comment
        -> Collapse JSP Comment

Those messages in ide8/modules/locale/org-netbeans-modules-html-editor_<LANG>.jar,
but not localized. So, I guess, this is I18n issue.


To Reproduce: 

1. Create JSP file in a project, in Japanese env.
2. Open #1.
3. In JSP editor, right click and select Code Folds.
4. Above messages are not localized.
Comment 1 Kenji Tachibana 2008-01-25 10:38:35 UTC
Change category to html/editor
Comment 2 Kenji Tachibana 2008-01-25 10:50:15 UTC
Added I18N keyword 
Comment 3 Ken Frank 2008-01-25 16:28:15 UTC
I don't see some of these messages in current nb 6.1 or the ones seen are from
localized bundle files, but it might happen in certain cases. am changing to p2
since is a message situation.

ken.frank@sun.com
Comment 4 Marek Fukala 2008-01-25 16:40:17 UTC
fixed

/cvs/web/jspsyntax/src/org/netbeans/modules/web/core/syntax/resources/JSP.nbs,v  <--  JSP.nbs
new revision: 1.10; previous revision: 1.9
done
Checking in Bundle.properties;
/cvs/web/jspsyntax/src/org/netbeans/modules/web/core/syntax/resources/Bundle.properties,v  <--  Bundle.properties
new revision: 1.13; previous revision: 1.12
done
Comment 5 kaa 2008-01-28 17:31:01 UTC
I couldn't reproduce using above steps.
Comment 6 kaa 2008-01-28 17:31:34 UTC
Created attachment 55662 [details]
image
Comment 7 kaa 2008-01-28 17:32:53 UTC
Seems the were removed from 6.1
Comment 8 kaa 2008-01-28 17:34:23 UTC
v
Comment 9 Ken Frank 2008-01-28 18:35:10 UTC
kaa, are you using 6.0 (or 6.0.1) builds ? thats what this issue is being filed on;
see version identifier in this issue.

if you were using a build of nb6.1, that is not accurate build to use.

if that is true this needs to be reopened.


in 6.1 these msgs are missing but that is a bug in itself and has been filed
to add the msgs back; please use that issue to verify using 6.1 when it is fixed.

ken.frank@sun.com
Comment 10 kaa 2008-01-30 17:09:59 UTC
reproducible:

Product Version: NetBeans IDE Dev (Build 200801291616)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
http://smetiste.czech.sun.com/builds/netbeans/6.0.1/daily/latest/

Comment 11 Marek Fukala 2008-02-20 14:56:21 UTC
The implementation of the foldings has changed completely now. We no longer use Schlieman engine. Instead of that the
HTML, CSS and JavaScript folds are provided by GSF and the JSP folds by separated JspFoldManager. 

Currently there are no language specific actions in the Code Folds menu for none of these languages.

Closing this issue since it is no longer valid (after the javascript2 repo merge to trunk, which happens today) and
filling a new one (Issue #127886) describing the missing folds actions.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo