Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 125720 - Custom tasks like JPDAStart, ... may use inconsistent MasterFS
Custom tasks like JPDAStart, ... may use inconsistent MasterFS
Status: RESOLVED WONTFIX
Product: projects
Classification: Unclassified
Component: Ant Project
6.x
All All
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@projects
:
: 126454 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-22 09:50 UTC by rmatous
Modified: 2010-04-02 20:12 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
warnings, dumpstacks (8.73 KB, text/plain)
2008-01-28 16:56 UTC, rmatous
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rmatous 2008-01-22 09:50:32 UTC
Generally jumping from running ant script into netbeans code (custom tasks, loggers) there is danger that the code will
use FileObjects that may not know about previous ant file changes. This may lead to bugs like #125090 which is now fixed
because FileUtil.toFileObject does internally refresh and thus reveals the changes. But whatever other call like
getFileObject, findResource could lead to bug because these methods rely on its caches (and do not validate them, by
additional check if file exists).
Comment 1 Milan Kubec 2008-01-22 09:54:08 UTC
Until there is real bug caused by this issue lowering priority to P3.
Comment 2 rmatous 2008-01-22 09:55:48 UTC
After finishing there is properly called refresh(BridgeIml) but its late.
Comment 3 rmatous 2008-01-22 10:02:32 UTC
No real bugs yet OK, but I would kindly ask for fast evaluation because I find it potentially dangerous. So, please look
at it and if you are really sure this can't bring new P1, then easily lower to P3.
Comment 4 Milos Kleint 2008-01-22 11:00:30 UTC
webapp deployment is in the same situation.
Comment 5 Milan Kubec 2008-01-25 07:28:03 UTC
I'll try to investigate.
Comment 6 rmatous 2008-01-28 16:56:46 UTC
Created attachment 55658 [details]
warnings, dumpstacks
Comment 7 Lukas Hasik 2008-02-01 14:28:32 UTC
*** Issue 126454 has been marked as a duplicate of this issue. ***
Comment 8 Lukas Hasik 2008-02-01 14:33:50 UTC
*** Issue 126204 has been marked as a duplicate of this issue. ***
Comment 9 rmatous 2008-02-04 09:47:45 UTC
Lowering priority cause masterfs should now somehow catch changes caused by ant scripts rinning in the same VM cause
TopSecurityManager was harnessed to deliver information about changes into masterfs.
Comment 10 Lukas Hasik 2008-04-10 21:24:25 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 11 Jesse Glick 2010-04-02 20:12:02 UTC
No known visible problems?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo