Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 125704 - Support Fetch extension
Support Fetch extension
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P2 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
:
: 120595 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 19:41 UTC by Jesse Glick
Modified: 2008-01-31 13:23 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
65122_d28df42b4215 - adding Fetch support (23.32 KB, text/plain)
2008-01-31 07:54 UTC, John Rice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2008-01-21 19:41:22 UTC
See issue #125013 for background. Since pulling and merging is a basic part of Hg workflow, needed whenever you want to
push and someone else has gotten there first, I suggest supporting the Fetch extension or its equivalent, either as

1. A menu item Fetch running 'hg fetch'. Safest, since the logic is a tested part of Hg itself.

2. A dialog displayed after pulling creates new local heads prompting you to merge. (If no new heads created, update.)
Comment 1 Padraig Obriain 2008-01-30 11:08:14 UTC
*** Issue 120595 has been marked as a duplicate of this issue. ***
Comment 2 John Rice 2008-01-31 07:54:11 UTC
changeset:   65122:d28df42b4215
user:        jrice@netbeans.org
date:        Wed Jan 30 22:50:40 2008 +0000
summary:     #125704: Support for Fetch Extension - also prompts user and modifies ~/.hgrc if fecth extension not there

Comment 3 John Rice 2008-01-31 07:54:54 UTC
Created attachment 55813 [details]
65122_d28df42b4215 - adding Fetch support
Comment 4 John Rice 2008-01-31 08:05:16 UTC
Committed
Comment 5 John Rice 2008-01-31 08:33:41 UTC
Note in Head: rev 65269 cset d28df42b4215
Comment 6 Jesse Glick 2008-01-31 13:23:49 UTC
You don't actually need to modify ~/.hgrc, you just need to use

  hg --config extensions.fetch= fetch


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo