Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 125698 - [65cat] No direct way to change the 'Add Leading Star in Comment' option
[65cat] No direct way to change the 'Add Leading Star in Comment' option
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Editor
6.x
All All
: P1 with 1 vote (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
65fixes2-verified
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 17:35 UTC by Michel Graciano
Modified: 2009-02-19 21:08 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Settings for 6.5 daily builds... (20.34 KB, image/png)
2008-07-18 14:53 UTC, Michel Graciano
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2008-01-21 17:35:05 UTC
There is no obvious way to change the 'Add Leading Star in Comment' property. The Help has this entry yet, what I think
is from 5.X versions. To do the change, is necessary go to Advanced Options and edit the Java Indentation Engine. I am
sure this option is important and should be resurrected.
Comment 1 Vitezslav Stejskal 2008-01-22 14:41:14 UTC
Yes, this sounds useful. Maybe we should add it to the java formatting options.
Comment 2 josephcz 2008-01-30 16:55:09 UTC
I agree, this is something I use all the time... I could not even find it
in the Advanced Options in "NetBeans IDE 6.0 (Build 200711261600)" and
had to manually edit the config file (i.e. copy the file from 6.0 beta 2)
in order to disable the "Add Leading Star in Comment" option.

The "Java Code" -> "Formatting" tab like the right place to put this.
Comment 3 Jan Becicka 2008-02-14 15:27:11 UTC
P4 imo
Comment 4 misterm 2008-02-18 17:28:22 UTC
Actually, all useful options are supposed to be moved to the Options dialog and this option certainly is missed. I think
it is a P3.
Comment 5 Michel Graciano 2008-07-14 21:02:04 UTC
There is no more way to update it for 6.5 version since the all the Advanced Options for editor was removed. Since there
is no more workaround or something else to set this property, IMO it is a P1 now.
Comment 6 Petr Dvorak 2008-07-18 12:36:12 UTC
Hi "hmichel"!

Advanced options are still present in 6.5 - they will not be removed until all important settings are transfered to
standard options. This issue does not qualify to P1 following the bug priority guidelines
(http://qa.netbeans.org/bugzilla/bug_priority_guidelines.html), I will push it back to P3, which can be translated as
"normal priority". P1 issues are reserved to data loss, project corruptions, and so on...

With best regards,

Petr Dvorak
Comment 7 Michel Graciano 2008-07-18 14:45:15 UTC
For build 200807170007 there is no settings for it. See the attachment. I am setting to P1, since guidelines say
regression is P1. See the josephcz comments that since 6.0 this option is not easy to define.
Comment 8 Michel Graciano 2008-07-18 14:53:47 UTC
Created attachment 64969 [details]
Settings for 6.5 daily builds...
Comment 9 Lukas Hasik 2008-07-18 15:14:32 UTC
This is not regression. It is planned change - see issue 90522. 
The advanced option will be removed completely for NB 6.5 
If you miss a setting then ask the appropriated module owners to provide the setting on a panel in Options panels.
Comment 10 Jiri Kovalsky 2008-07-18 15:36:14 UTC
Lukasi, Michel is right. The option is important and belongs to the Java formatting options. From this point of view
it's really a regression. Thus raising to P2. I have talked with Editor developers and they will fix this shortly.
Comment 11 Jan Becicka 2008-07-21 16:15:28 UTC
Ondro, where should we put this setting?
Comment 12 Jan Becicka 2008-07-22 11:59:58 UTC
Ondra is on vacation. ccing Jano
Comment 13 Ondrej Langr 2008-07-23 12:22:24 UTC
I'm sorry for the delay. In the current organization of the formatting tab, it doesn't really fit to any of the categories. 

I suggest to add it to "Tabs and Indents" category under "Indent Case Statements in Switch" where it gets good
visibility (it's the default category) and consider separate "Comments" category for the future if there will be more
comment related options.

Assigning back to dbalek .. 
Comment 14 Dusan Balek 2008-07-23 15:29:05 UTC
Fixed.

changeset 2d85db1e2afd in main
details: http://hg.netbeans.org/main?cmd=changeset;node=2d85db1e2afd
Comment 15 Quality Engineering 2008-07-24 04:08:14 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #341 build
Changeset: http://hg.netbeans.org/main/rev/2d85db1e2afd
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #125698: [65cat] No direct way to change the 'Add Leading Star in Comment' option - fixed.
Comment 16 Michel Graciano 2008-07-24 15:20:00 UTC
v. build 200807240010
Comment 17 Michel Graciano 2008-11-14 16:57:44 UTC
I can't believe but it was removed AGAIN... The revision http://hg.netbeans.org/main/rev/9e509c00f63a show a merge where
this was removed and now it is impossible to change it again. I hope to see it for FCS.
Comment 18 Marian Mirilovic 2008-11-14 19:16:44 UTC
Too late for NB 6.5 ... before evaluation by Devs, I add it at least on the list for Patch 1 
Comment 19 Lukas Hasik 2008-11-14 19:45:55 UTC
michel is right.  vstejskal removed it on 8/13
Comment 20 Michel Graciano 2008-11-14 19:52:26 UTC
I am really sad to know it... I am really afraid about this kind of regression. How could this happen? Code was removed
without any question? Where is the tests? I am now investigating if I had any another regression, this is already the
second during 6.5 builds.
When you expect make the patch 1 available?
Comment 21 pgebauer 2008-11-24 09:31:03 UTC
The issue didn't pass the nomination process by nomination cut-off date. It has been marked as 65fixes2-candidate.
Comment 22 Dusan Balek 2008-12-02 16:16:53 UTC
Should be fixed again.

changeset be79c36a4232 in main
details: http://hg.netbeans.org/main?cmd=changeset;node=be79c36a4232
Comment 23 Quality Engineering 2008-12-05 06:25:44 UTC
Integrated into 'main-golden', will be available in build *200812050201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/be79c36a4232
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #125698: No direct way to change the 'Add Leading Star in Comment' option - fixed.
Comment 24 Jiri Prox 2009-01-13 10:28:51 UTC
verified in
Product Version: NetBeans IDE Dev (Build 20090112033331)
Java: 1.6.0_11; Java HotSpot(TM) Client VM 11.0-b16
System: Linux version 2.6.24-23-generic running on i386; UTF-8; en_US (nb)
Comment 25 pgebauer 2009-01-14 21:36:53 UTC
The fix has been ported into the release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/b7b2f78f6381


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo