Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 125576 - refactor move static method
refactor move static method
Status: RESOLVED DUPLICATE of bug 57767
Product: editor
Classification: Unclassified
Component: Refactoring
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@ide
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-18 16:08 UTC by fommil
Modified: 2008-10-16 18:53 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fommil 2008-01-18 16:08:16 UTC
In NetBeans 6.0, the refactoring support does not allow refactoring of static methods from one class to another. Right clicking on a static method and 
choosing Refactor -> Move will attempt to move the class, not the method. It would be good to have support for safe moving of static methods.
Comment 1 Jan Pokorsky 2008-10-16 18:53:28 UTC

*** This issue has been marked as a duplicate of 57767 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo