Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 125575 - [Safe delete] Restored file is not visible in project view after undo
[Safe delete] Restored file is not visible in project view after undo
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Refactoring
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@java
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-18 16:08 UTC by Jiri Prox
Modified: 2008-05-30 12:30 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Simple fix (1.09 KB, text/plain)
2008-01-18 17:14 UTC, rmatous
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2008-01-18 16:08:09 UTC
Product Version: NetBeans IDE Dev (Build 20080117070849)
Java: 1.6.0_10-ea; Java HotSpot(TM) Client VM 11.0-b09
System: Linux version 2.6.17-12-generic running on i386; UTF-8; en_US (nb)

Restored file in not visible in project view after safe delete undo. Focusing another application or creating new file
for refreshing the window content helps.
Comment 1 Jan Becicka 2008-01-18 16:22:59 UTC
This is probably another regression caused by 123542.

Comment 2 rmatous 2008-01-18 17:14:15 UTC
Created attachment 55255 [details]
Simple fix
Comment 3 rmatous 2008-01-18 17:18:40 UTC
Works now. Anyway you should fix your code according to attached patch. 
Comment 4 Jan Becicka 2008-01-21 16:04:59 UTC
Thanks for patch:
Checking in BackupFacility.java;
/cvs/refactoring/api/src/org/netbeans/modules/refactoring/spi/BackupFacility.java,v  <--  BackupFacility.java
new revision: 1.14; previous revision: 1.13
done
Comment 5 Jiri Prox 2008-05-30 12:30:30 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo