Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 125530 - deadlock when resolving db connection
deadlock when resolving db connection
Status: RESOLVED DUPLICATE of bug 121694
Product: javaee
Classification: Unclassified
Component: Code
6.x
All Windows XP
: P1 (vote)
: TBD
Assigned To: John Baker
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-18 02:28 UTC by Chris Webster
Modified: 2008-01-19 03:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stack trace showing deadlock (22.38 KB, text/plain)
2008-01-18 02:29 UTC, Chris Webster
Details
snapshot of about window, showing configuration (58.42 KB, image/jpeg)
2008-01-18 16:44 UTC, Chris Webster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Webster 2008-01-18 02:28:02 UTC
I encountered a deadlock when resolving a database connection. The stack trace implies the j2ee.ui common module is
involved so I am filing the issue here.
Comment 1 Chris Webster 2008-01-18 02:29:11 UTC
Created attachment 55227 [details]
stack trace showing deadlock
Comment 2 John Baker 2008-01-18 08:45:29 UTC
Is this 6.0 final release or pre-release ?

I had fixed a deadlock in this area, just before the 6.0 release
Comment 3 John Baker 2008-01-18 08:54:23 UTC
It looks like a pre-6.0 release is used.

In the 6.0 final release codebase, line 262 is not inside the getSize method

However, the attached stack trace shows that execution reaches line 262 in method getSize() .  This seems to indicate
that the build used is not the 6.0 release.

- locked <0x1389a870> (a org.netbeans.modules.j2ee.common.ui.MissingDatabaseConnectionWarning$DatasourceListModel)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)
"AWT-EventQueue-1":
	at
org.netbeans.modules.j2ee.common.ui.MissingDatabaseConnectionWarning$DatasourceListModel.getSize(MissingDatabaseConnectionWarning.java:262)
	- waiting to lock <0x1389a870> (a org.netbeans.modules.j2ee.common.ui.MissingDatabaseConnectionWarning$DatasourceListModel)
Comment 4 John Baker 2008-01-18 08:55:09 UTC
Please try with 6.0 release.  If you're still seeing this exception then you can reopen this bug.
Comment 5 John Baker 2008-01-18 09:04:49 UTC
There was an earlier bug in 6.0 RC1 that I had fixed, similar stack trace as attached (same getSize() on line 262)
Comment 6 Chris Webster 2008-01-18 16:41:53 UTC
This is based on the 6.0 final bits, reopening. 
Comment 7 Chris Webster 2008-01-18 16:44:38 UTC
Created attachment 55254 [details]
snapshot of about window, showing configuration
Comment 8 John Baker 2008-01-18 17:52:45 UTC
Correction, another issue 121694 was filed during RC1 as a P2. 
This has since been fixed.

The attached stack trace is from the final release.  In the trunk, for MissingDatabaseConnectionWarning, the getSize
method is on a different line number.

I'll check with QE if this could be a patch candidate

Closing as duplicate of 121694

*** This issue has been marked as a duplicate of 121694 ***
Comment 9 Chris Webster 2008-01-19 01:31:42 UTC
I am not sure this is a actually a duplicate of the mentioned bug as this has already been fixed and the problem still
occurs. 
Comment 10 John Baker 2008-01-19 02:54:29 UTC
> the problem still occurs. 

Did you try the trunk build ?
(in desc9, if not clear, the fix is in the trunk)
Comment 11 John Baker 2008-01-19 03:00:21 UTC
to re-clarify

the fix did not make it in 6.0  , try a trunk build,  fix went in on Dec 11, so please use a trunk build, built after Dec 
12

( from the duplicate bug http://www.netbeans.org/issues/show_bug.cgi?id=121694#desc23 )


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo