Bug 125378 - Review extension to TypeProvider results
Review extension to TypeProvider results
Status: RESOLVED FIXED
Product: utilities
Classification: Unclassified
Component: Jump To
6.x
All All
: P2 (vote)
: 6.x
Assigned To: apireviews
Jiri Prox
http://wiki.netbeans.org/wiki/view/Na...
: API_REVIEW_FAST
: 125865 (view as bug list)
Depends on:
Blocks: 124980
  Show dependency treegraph
 
Reported: 2008-01-16 13:13 UTC by Pavel Flaska
Modified: 2008-03-31 13:23 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
diff utilities/jumpto/ ruby/ cnd/ java/ (25.35 KB, patch)
2008-01-16 13:27 UTC, Pavel Flaska
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Flaska 2008-01-16 13:13:25 UTC
As a part of startup improvements, we want to allow user to open class even when scanning is running - it can lead to
incomplete or inaccurate results. To implement it correctly, we need to extend "Go To Type" dialog with message
informing user about possibly incomplete results. -- That is the reason for SPI change suggested below.
Comment 1 Pavel Flaska 2008-01-16 13:27:03 UTC
Created attachment 55140 [details]
diff utilities/jumpto/ ruby/ cnd/  java/
Comment 2 Jaroslav Tulach 2008-01-16 16:39:31 UTC
I like this version of the xyzTypeNames method more as it allows compatible additions to parameters as well as return 
types in future. I see it as a good step towards real API, not just friend one.
Comment 3 Pavel Flaska 2008-01-18 14:50:23 UTC
Checking in utilities/jumpto/manifest.mf;
/cvs/utilities/jumpto/manifest.mf,v  <--  manifest.mf
new revision: 1.6; previous revision: 1.5
done
Checking in utilities/jumpto/src/org/netbeans/modules/jumpto/type/GoToTypeAction.java;
/cvs/utilities/jumpto/src/org/netbeans/modules/jumpto/type/GoToTypeAction.java,v  <--  GoToTypeAction.java
new revision: 1.14; previous revision: 1.13
done
RCS file: /cvs/utilities/jumpto/src/org/netbeans/modules/jumpto/type/TypeProviderAccessor.java,v
done
Checking in utilities/jumpto/src/org/netbeans/modules/jumpto/type/TypeProviderAccessor.java;
/cvs/utilities/jumpto/src/org/netbeans/modules/jumpto/type/TypeProviderAccessor.java,v  <--  TypeProviderAccessor.java
initial revision: 1.1
done
Checking in utilities/jumpto/src/org/netbeans/spi/jumpto/type/TypeProvider.java;
/cvs/utilities/jumpto/src/org/netbeans/spi/jumpto/type/TypeProvider.java,v  <--  TypeProvider.java
new revision: 1.4; previous revision: 1.3
done
Checking in ruby/gsf/src/org/netbeans/modules/gsf/GsfTypeProvider.java;
/cvs/ruby/gsf/src/org/netbeans/modules/gsf/GsfTypeProvider.java,v  <--  GsfTypeProvider.java
new revision: 1.5; previous revision: 1.4
done
Checking in cnd/gotodeclaration/src/org/netbeans/modules/cnd/gotodeclaration/type/CppTypeProvider.java;
/cvs/cnd/gotodeclaration/src/org/netbeans/modules/cnd/gotodeclaration/type/CppTypeProvider.java,v  <--  CppTypeProvider.java
new revision: 1.8; previous revision: 1.7
done
Checking in java/sourceui/src/org/netbeans/modules/java/source/ui/JavaTypeProvider.java;
/cvs/java/sourceui/src/org/netbeans/modules/java/source/ui/JavaTypeProvider.java,v  <--  JavaTypeProvider.java
new revision: 1.11; previous revision: 1.10
done
Comment 4 Martin Krauskopf 2008-03-31 13:23:50 UTC
*** Issue 125865 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo