Bug 125341 - Quick way to add dependency on already open project
Quick way to add dependency on already open project
Status: RESOLVED DUPLICATE of bug 75520
Product: projects
Classification: Unclassified
Component: Generic Projects UI
6.x
All All
: P2 (vote)
: 6.x
Assigned To: jrojcek
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-16 05:43 UTC by Vince Kraemer
Modified: 2010-04-08 21:18 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vince Kraemer 2008-01-16 05:43:09 UTC
many of the project types have a page in the project customizer that allow you to add a dependency on a Project.

Pressing the Add Project button seems like it always opens up a fancy file chooser dialog in some default location...
which is almost always wrong [at least the first time].

It would be nice to be able to press a button to select one of the projects that is already open in the IDE....

Consider the following steps...

Create a new web app project.
Create a new java library project.

Then try to make the web app depend on the java library.  It is possible. but it can be pretty painful, if the two
projects are in different sub directories....

BONUS POINTS: implement a DnD to create the dependencies... (select java library project... drag onto web app project...
drop... defines a dependency...)
Comment 1 Vince Kraemer 2008-10-31 17:35:18 UTC
thanks for taking a look and considering it for 7.0
Comment 2 Milan Kubec 2008-11-12 12:30:26 UTC
Jano, please provide HIE assistance with this issue. Thanks.
Comment 3 Jesse Glick 2010-04-08 21:18:07 UTC
Not an exact duplicate, but essentially the same.

*** This bug has been marked as a duplicate of bug 75520 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo