Bug 125136 - Installation of Groovy Plugin fails (Missing required modules for Plugin Java Source)
Installation of Groovy Plugin fails (Missing required modules for Plugin Java...
Status: RESOLVED WONTFIX
Product: groovy
Classification: Unclassified
Component: Code
6.x
All Linux
: P1 (vote)
: 6.x
Assigned To: martin_adamek
issues@groovy
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-11 19:34 UTC by deamon
Modified: 2008-10-30 14:24 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Missing required modules for Plugin Java Source (14.61 KB, image/png)
2008-01-11 19:36 UTC, deamon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description deamon 2008-01-11 19:34:22 UTC
First I added
http://deadlock.netbeans.org/hudson/job/javadoc-nbms/lastSuccessfulBuild/artifact/nbbuild/nbms/updates.xml.gz to the
plugin manager then I choosed the groovy plugin and clicked on "install". But in the new opened window appears the message: 
Missing required modules for Plugin Java Source:
Java Source [module org.netbeans.modules.java.source = 1]
Comment 1 deamon 2008-01-11 19:36:00 UTC
Created attachment 54965 [details]
Missing required modules for Plugin Java Source
Comment 2 martin_adamek 2008-01-14 13:13:40 UTC
You did it in 6.0 final?
Comment 3 deamon 2008-01-14 14:03:16 UTC
Yes, I use NetBeans 6.0 final.
Comment 4 martin_adamek 2008-01-14 14:17:38 UTC
So that's the problem. Groovy/Grails support is not available for 6.0 (only early snapshot on plugins.netbeans.org is available) because we are using new APIs 
introduced after 6.0. Currently you must use daily builds to test Groovy/Grails support. I am closing this as wontfix.
Comment 5 deamon 2008-01-15 07:09:59 UTC
But it is curious that the plugin works with NetBeans 6.0 final under Windows.
Comment 6 martin_adamek 2008-01-21 12:44:39 UTC
I don't understand either. Anyway, you should not add that UC to 6.0 final. It is not compatible.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo