Bug 125119 - Better UI of balloon like tooltip
Better UI of balloon like tooltip
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
: PLAN, UI
: 129978 129979 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-11 15:26 UTC by Lukas Hasik
Modified: 2008-06-03 17:11 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
current (01/11) status of the ballooon like tooltip (7.76 KB, image/jpeg)
2008-01-11 15:27 UTC, Lukas Hasik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2008-01-11 15:26:32 UTC
please, include an UI designer into designing of the balloon like tooltop UI. 

To be specific - I don';t like following things. IMO, the UI is poor even if the feature idea itself is nice
1, rounded corner aren't smooth enough
2, shadow is too simple. It should have a blur edge, etc.
3, the shadow is too far. It makes feeling that the tooltip is too far from the IDE surface. OTOH, the tooltip arrow
doesn't create this feeling
4, make tooltip arrow more fancy. Why is it straight line, make it a curve ;)
Comment 1 Lukas Hasik 2008-01-11 15:27:25 UTC
Created attachment 54954 [details]
current (01/11) status of the ballooon like tooltip
Comment 2 Stanislav Aubrecht 2008-01-11 17:32:44 UTC
great ideas:)
please provide a picture of a 'fancy' balloon and i'll try to re-implement accordingly...
Comment 3 mbien 2008-01-29 17:16:28 UTC
i recommend to take a look at this project: https://balloontip.dev.java.net/

it is probably easier to use this compared to reimplementing everything from scratch :) The other advantage is: it has
already a API for customized looks of the ballone. In future it could also be added as public module to the patform...
(I'm just thinking loud)
Comment 4 kirillkh 2008-01-29 19:29:50 UTC
My first impression after seeing the new tooltip: "omg, Clippy!"

So, what made me recall this evil creature?
- the round shape
- the comics-like corner that grows out of the arrow
- the color
- the fact that the beast tries its best to jump on my screen each time it gets a chance and stick to it as long as it can
- the X button shape
- the shadow

Suggestions:
- give the balloon an elegant gray/metal color
- make it just large enough to fit the text and the X button
- make the rounded corners much less rounded
- remove the comics corner
- make it disappear fast
- disable pop-up on mouse roll-over
Comment 5 kirillkh 2008-01-29 19:31:42 UTC
- disable pop-up on start-up; just change the notification icon
Comment 6 kirillkh 2008-01-29 19:32:49 UTC
Ah, actually, the icon doesn't appear, when there are no updates, so no additional indications are needed. Just don't
pop it up.
Comment 7 mbien 2008-01-31 15:12:32 UTC
article about ballontip:
http://www.javaworld.com/javaworld/jw-01-2008/jw-01-opensourcejava1.html
Comment 8 one 2008-02-04 14:43:30 UTC
Maybe support growl (Mac) and snarl (Win32)? That'd be cool. 

I really dislike every app having their own notification system, and at least Growl for Mac is pretty standard.

http://growl.info/ (growl, Mac)
http://www.fullphat.net/ (snarl, Win32)
Comment 9 kirillkh 2008-02-04 15:06:48 UTC
The screenshots from growl and snarl are much more to my taste. Of course, it's impossible to rely on them as libraries,
but NetBeans can just borrow the graphics.
Comment 10 one 2008-02-04 15:53:16 UTC
Why not use them as libraries? Borrow graphics is good, but then you have ANOTHER system. I like OS integration very much. 
Comment 11 pedalshoe 2008-03-09 15:43:31 UTC
How about "sliding" a decorated alert BOX; Include the details then after a user configurable amount of time, "fade" the
BOX away.
-Christopher
Comment 12 Tim Lebedkov 2008-03-09 22:42:56 UTC
(if it is not yet too late)
IMHO:
NB has a good and simple notification system (status line). I don't like these balloons. Whether in Windows nor in NB.
They distract and force me to click on them because I don't know how long they will stay. Why do we need another sort of
user notification? Let the update center icon blink, run a fancy animation there or something similar. Say "NO" to
balloons :-)!
Comment 13 Stanislav Aubrecht 2008-03-11 18:12:26 UTC
> They distract and force me to click on them because I don't know how long they will stay.

i think that's exactly why there's a balloon instead of any other type of notification. it's supposed to force users to
download the latest patches to increase the quality of ide and decrease income of duplicate/already-fixed bugs:)
Comment 14 kirillkh 2008-03-11 22:38:39 UTC
Sorry, but the update system isn't ready for serious use. It simply doesn't work well, when switching between different
NB versions with different plugins versions. It doesn't even allow you to choose, where to install a plugin - base dir
or user dir. Every time I tried to use it seriously, I ended up with plugin dependency hell. That's why I have stopped
using the update system for updating plugins and don't recommend it to other people.

Now please stop forcing me into things that get in my way.
Comment 16 Jiri Rechtacek 2008-03-13 10:03:07 UTC
*** Issue 129978 has been marked as a duplicate of this issue. ***
Comment 17 Jiri Rechtacek 2008-03-13 10:04:27 UTC
*** Issue 129979 has been marked as a duplicate of this issue. ***
Comment 18 _ tboudreau 2008-03-13 19:29:45 UTC
Also consider some use of translucency so it is possible to tell what is behind the bubble without dismissing it.
Comment 19 Stanislav Aubrecht 2008-03-17 18:24:56 UTC
i've added anti-aliasing, improved the shadow a bit and the balloon now disappears after 30sec

432aad89cc8a
Comment 20 Stanislav Aubrecht 2008-03-17 18:31:17 UTC
(i'll wait with hg push till tomorrow to have repository problems sorted out...)
Comment 21 tsomerville 2008-04-16 20:12:34 UTC
Please add a way to disable the balloon (from within the balloon itself).
I can't stand these things.

I already like the way it is - you hover and it lets you know if any updates are available.
Or, you could make the icon turn red.
Or, you could put a --small-- number out to the left or right of it.

Anything that blinks, flashes or begs my attention is a bad UI experience.
Comment 22 kirillkh 2008-04-16 20:56:22 UTC
Changing back to DEFECT.
Comment 23 Antonin Nebuzelsky 2008-04-17 23:47:55 UTC
> Anything that blinks, flashes or begs my attention is a bad UI experience.

Actually we were deciding between a modal dialog box "New updates available. Do you want to install them now? Yes/No"
which would slap you in the face on every startup until you pressed Yes, and between this balloon like tooltip.

I think our choice is a good one... ;)

So, simply speaking, begging your attention is exactly the purpose we had in mind when designing this little thing.
Comment 24 kirillkh 2008-04-18 01:45:31 UTC
> begging your attention is exactly the purpose we had in mind when designing this little thing
Don't you find this a bit arrogant? If you get enough people upset with your design choices, someone will make a hack to
disable the damn thing.
Comment 25 Antonin Nebuzelsky 2008-04-18 09:59:00 UTC
Is it really that bad? Many systems which release regular updates online want the users to install the bug fixes as soon
as possible. For example both Ubuntu and Windows have an icon in their system tray which also shows a balloon-like
tooltip drawing user's attention to the newly available updates. I don't agree its arrogant. Sorry, if it seams so.

The small non-flashing icon in the right corner of the status bar is not enough. It can easily go unnoticed by users.

Can you suggest some other way of making it obvious to all users there are new updates?
Comment 26 Antonin Nebuzelsky 2008-04-18 19:39:46 UTC
We discussed it again here and after the discussion I think we should do one change. The balloon could perhaps pop up
only once each time a new set of updates is detected. This way all users would be notified clearly about a new update
available and the icon would stay in the status bar until the updates are installed, but the balloon would not reappear
at every restart. Reopening this issue for 6.5.

kirillkh, tsomerville, would this work for you?
Comment 27 kirillkh 2008-04-20 13:45:03 UTC
Yes, much better, thank you. But please also disable automatic pop-up of the balloon on rolling mouse over the circle in
the status bar. I would suggest a regular tool-tip instead (and please make it disappear fast!)
Comment 28 Jiri Rechtacek 2008-05-25 19:26:54 UTC
http://hg.netbeans.org/core-main/rev/d48d84d833ee
Comment 29 Quality Engineering 2008-06-03 04:10:14 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #234 build
Changeset: http://hg.netbeans.org/main/rev/d48d84d833ee
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #125119: Better UI of balloon like tooltip
Comment 30 Jiri Rechtacek 2008-06-03 15:56:02 UTC
FYI: Since NetBeans6.5 you can customize appearance of balloon-like by new options introduced in
http://wiki.netbeans.org/FaqPluginManagerCustomization#section-FaqPluginManagerCustomization-ToCustomizeAppearanceOfBalloonLikeTooltipSinceNB6.5
Comment 31 _ tboudreau 2008-06-03 17:11:09 UTC
Dear God in Heaven, why the ^&#$ do I want any of these options?!  I do not want to customize anything about the balloon tooltip.  This issue was about 
making it a bit less butt-ugly.

Somehow I'm reminded of Joel Spolsky's article about how the history of all design arguments is encoded in an application's options.

I am glad there is a way to turn it off, since it is obnoxious when doing demos on stage (usually done with a clean user dir to avoid trouble).  I'll take a look at 
a dev build and hopefully not be horrified and can verify this issue fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo