Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 125055 - XMLFoldManager : remove dependency on DocumentModel
XMLFoldManager : remove dependency on DocumentModel
Status: RESOLVED FIXED
Product: xml
Classification: Unclassified
Component: Text-Edit
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Samaresh Panda
issues@xml
:
: 127323 (view as bug list)
Depends on:
Blocks: 101156 116806
  Show dependency treegraph
 
Reported: 2008-01-10 19:30 UTC by Samaresh Panda
Modified: 2008-02-13 18:04 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samaresh Panda 2008-01-10 19:30:17 UTC
XMLFoldManager uses an implementation of DocumentModel. In other words, it uses XMLSyntaxParser and old editor APIs.
There are several issues with that and after discussions we have decided to remove that dependency and rewrite xml fold.
This will help solve several issues particularly some on performance.
Comment 1 Samaresh Panda 2008-02-08 04:28:30 UTC
Fix integrated: http://hg.netbeans.org/main/rev/26fbf1aa6d3a
The fold manager is completely re-written using lexer. It doesn't use the document model anymore.
Comment 2 Samaresh Panda 2008-02-13 18:04:18 UTC
*** Issue 127323 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo