Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 125014 - Fix imports feature
Fix imports feature
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Editor
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Rastislav Komara
issues@javafx
:
Depends on: 136056
Blocks: 130138
  Show dependency treegraph
 
Reported: 2008-01-10 09:28 UTC by Alexandr Scherbatiy
Modified: 2008-10-06 13:48 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2008-01-10 09:28:25 UTC
Steps to reproduce:

- Create an FX file:
  ----------------------
  Frame{}
  ----------------------
- Press <Ctrl+Shift+I>
  'import javafx.ui.Frame;' line is not added to the file.
Comment 1 Andrey Yamkovoy 2008-01-21 11:57:08 UTC
This feature is not implemented yet.
Comment 2 Alexandr Scherbatiy 2008-06-30 09:03:29 UTC
Does the openjfx-compiler contain stopper issues for the Fix Import feature? 
Comment 3 David Strupl 2008-06-30 09:12:20 UTC
No, this one depends just on #136056 which is not compiler dependent ...
Comment 4 David Strupl 2008-07-22 10:02:29 UTC
Re-assigning to Petr since it depends on "his" class index feature. We can still negotiate who will implement this one
after the class index is ready ;-)
Comment 5 David Strupl 2008-10-01 08:43:19 UTC
This is being worked on by Rasta for the last week.
Comment 6 Rastislav Komara 2008-10-03 13:02:56 UTC
Done.
Comment 7 Alexandr Scherbatiy 2008-10-06 13:48:53 UTC
verified in 2008-10-06_13-19-10.zip 


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo