Bug 125007 - I18N - "name" property not from Bundle.properties
I18N - "name" property not from Bundle.properties
Status: RESOLVED WONTFIX
Product: xml
Classification: Unclassified
Component: WSDL Tools
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Shivanand Kini
issues@xml
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-10 02:40 UTC by Ashizawa Kazunori
Modified: 2008-04-15 18:54 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ashizawa Kazunori 2008-01-10 02:40:22 UTC
I18N - "name" property not from Bundle.properties

Product Version: NetBeans IDE 6.0 (Build 200801091200)
Java: 1.6.0_03; Java HotSpot(TM) Client VM 1.6.0_03-b05
System: SunOS version 5.11 running on sparc; UTF-8; ja_JP (nb)

Steps:
1. create sample Travel Reservation Service project
2. open AirlineReservationService.wsdl
3. change to Partner view
4. click AirlineReservationPartnerLinkType
   "name" property is not from Bundle.properties
5. expand AirlineReservationPartnerLinkType
6. click AirlineReservationCallbackServiceRole
   "name" property is not from Bundle.properties
Comment 1 Ken Frank 2008-01-10 06:47:29 UTC
Kasha,
this might be something that is not meant to be translated or is part of the
travel schema itself, which comes from the sample itself, which would not be
translated; but we'll need to check on this.

there are certain things in these areas that are not to be translated.

ken.frank@sun.com
Comment 2 Ashizawa Kazunori 2008-01-10 08:28:20 UTC
Ken, thank you for your comment.

This issue can be reproduced by creating a new BPEL project, so
not specific to the sample.

For other elements, "name" property label (not in XML files, but
in property window on the IDE) is translatable and translated.
I assume that reported labels can also be translatable.
Comment 3 kaa 2008-01-15 16:26:04 UTC
Since this property was translated for other wsdl components and it starts with the capital N,
I believe it should be also translated for PartnerLinkType.
Comment 4 Vladimir Yaroslavskiy 2008-03-19 16:13:19 UTC
this issue is part of xml property editor (xml.wsdlui module),
reassign...
Comment 5 Ken Frank 2008-04-14 22:51:55 UTC
since this is about a missing message/label not from bundle file,
am moving to p2 as for other such situations.

ken.frank@sun.com
Comment 6 Shivanand Kini 2008-04-15 18:54:12 UTC
These are extensibility elements, the properties of which need not be localized. These are autogenerated from a schema
file, and it was decided that these need not be localized. 
Properties for which developers have provided custom property editors have provided localized names, hence some of them
are localized.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo