Bug 124985 - FileUtil.toFileObject() returns null for network shared file
FileUtil.toFileObject() returns null for network shared file
Status: RESOLVED DUPLICATE of bug 46813
Product: platform
Classification: Unclassified
Component: Filesystems
6.x
All All
: P2 (vote)
: TBD
Assigned To: rmatous
issues@platform
:
Depends on:
Blocks: 124651
  Show dependency treegraph
 
Reported: 2008-01-09 18:38 UTC by Sonali Kochar
Modified: 2008-12-22 10:11 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sonali Kochar 2008-01-09 18:38:59 UTC
I have mapped my unix home directory to my PC and am executing the following code

File srcFile = new File("\\sm-my_building_code-01\my_user_name\temp\newPurchaseOrder.xsd");
if(f.exists() )
    System.out.println("File exists);

File f = FileUtil.normalizeFile(srcFile);
if(f.exists())
    System.out.println("normalized file exists");

FileObject source = FileUtil.toFileObject(f);

I get a null FileObject and I am unable to proceed further. This above code is used in "External XML Schema Document "
new file wizard to copy files from shared network folders to a user specified target directory.
Comment 1 Peter Pis 2008-01-11 15:04:44 UTC
Reassigning to "openide" for evaluation.
Comment 2 rmatous 2008-01-14 19:22:23 UTC
UNC path isn't considered earlier than for 7.0

*** This issue has been marked as a duplicate of 46813 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo