Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 124973 - Project view nodes invade the Files explorer
Project view nodes invade the Files explorer
Status: RESOLVED WORKSFORME
Product: javaee
Classification: Unclassified
Component: Code
6.x
All Windows XP
: P3 (vote)
: 6.x
Assigned To: David Konecny
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 16:06 UTC by Vince Kraemer
Modified: 2008-01-16 17:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vince Kraemer 2008-01-09 16:06:33 UTC
I have a very recently updated (yesterday) build of the trunk.

I am using JDK 6 update 3 on Windows Vista.

I create an ent app that includes a web app.

The Project explorer is populated correctly.

I switch to the Files view and the node aren't folders... the nodes/trees are duplicates of the Project explorer.

I create a Java Application project... it seems fine. It's Project view doesn't invade the File view.

The Favorites view appears to be okay, too.

Note:  I had updated the tree a couple days ago and those builds had not had this behavior.
Comment 1 Vince Kraemer 2008-01-09 16:07:26 UTC
this looks like a problem in j2ee projects
Comment 2 David Konecny 2008-01-14 07:20:33 UTC
Vince, I cannot reproduce this on config below. There were almost no changes in web/projects in last weeks so I wonder
what could cause this. Could you please try it on fresh userdir with freshly created ear project and perhaps even on
different JDKs whether there is a pattern and whether it is reproducible always or only under some conditions. Also a
screenshot would be nice. Thanks, D.

NetBeans IDE Dev (Build 080111)
Windows Vista version 6.0 running on x86
1.6.0_05-ea; Java HotSpot(TM) Client VM 1.6.0_05-ea-b04; Sun Microsystems Inc.
Comment 3 Vince Kraemer 2008-01-16 17:09:36 UTC
I haven't been able to reproduce this with recent builds... it might have been a transient issue.  I will reopen this if
I run into it again.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo