Bug 124886 - java.lang.AssertionError: Line number is higher than lines in text
java.lang.AssertionError: Line number is higher than lines in text
Status: VERIFIED FIXED
Product: groovy
Classification: Unclassified
Component: Code
6.x
All All
: P1 (vote)
: 6.x
Assigned To: martin_adamek
issues@groovy
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 13:54 UTC by schmidtm
Modified: 2008-10-30 14:24 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
SearchController.groovy testcase (857 bytes, text/plain)
2008-01-08 13:55 UTC, schmidtm
Details
SearchService.groovy (6.96 KB, text/plain)
2008-01-08 14:05 UTC, schmidtm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schmidtm 2008-01-08 13:54:20 UTC
If one opens up the attached file, he'll get this exception.
You can either wait some time or doubleclick on SearchServie or searchService in line 3:

java.lang.AssertionError: Line number is higher than lines in text: 46
        at org.netbeans.modules.groovy.editor.AstUtilities.getOffset(AstUtilities.java:223)
        at org.netbeans.modules.groovy.editor.parser.GroovyParser.handleErrorCollector(GroovyParser.java:285)
        at org.netbeans.modules.groovy.editor.parser.GroovyParser.parseBuffer(GroovyParser.java:233)
        at org.netbeans.modules.groovy.editor.parser.GroovyParser.parseFiles(GroovyParser.java:109)
        at org.netbeans.napi.gsfret.source.Source.moveToPhase(Source.java:880)
        at org.netbeans.napi.gsfret.source.CompilationController.toPhase(CompilationController.java:114)
        at org.netbeans.modules.gsfret.editor.codetemplates.GsfCodeTemplateFilter.run(GsfCodeTemplateFilter.java:107)
        at org.netbeans.modules.gsfret.editor.codetemplates.GsfCodeTemplateFilter.run(GsfCodeTemplateFilter.java:67)
        at org.netbeans.napi.gsfret.source.Source.runUserActionTask(Source.java:470)
        at org.netbeans.modules.gsfret.editor.codetemplates.GsfCodeTemplateFilter.<init>(GsfCodeTemplateFilter.java:83)
        at org.netbeans.modules.gsfret.editor.codetemplates.GsfCodeTemplateFilter.<init>(GsfCodeTemplateFilter.java:67)
        at
org.netbeans.modules.gsfret.editor.codetemplates.GsfCodeTemplateFilter$Factory.createFilter(GsfCodeTemplateFilter.java:121)
        at
org.netbeans.lib.editor.codetemplates.CodeTemplateManagerOperation.getTemplateFilters(CodeTemplateManagerOperation.java:232)
        at org.netbeans.lib.editor.codetemplates.SurroundWithFix.getFixes(SurroundWithFix.java:68)
        at org.netbeans.lib.editor.codetemplates.AbbrevDetection.showSurroundWithHint(AbbrevDetection.java:367)
        at org.netbeans.lib.editor.codetemplates.AbbrevDetection.access$000(AbbrevDetection.java:90)
        at org.netbeans.lib.editor.codetemplates.AbbrevDetection$1.actionPerformed(AbbrevDetection.java:162)
        at javax.swing.Timer.fireActionPerformed(Timer.java:271)
        at javax.swing.Timer$DoPostEvent.run(Timer.java:201)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
        at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 1 schmidtm 2008-01-08 13:55:52 UTC
Created attachment 54816 [details]
SearchController.groovy testcase
Comment 2 martin_adamek 2008-01-08 14:01:56 UTC
I can't reproduce, can you please attach also SearchService.groovy ?
Comment 3 schmidtm 2008-01-08 14:05:35 UTC
Created attachment 54818 [details]
SearchService.groovy
Comment 4 martin_adamek 2008-01-08 14:09:48 UTC
Forget it I can reproduce it now, error in referenced file must be on higher line that currently edited has.
Comment 6 Quality Engineering 2008-05-20 05:17:56 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #206 build
Changeset: http://hg.netbeans.org/main/rev/e3b2edd87b0e
User: Martin Adamek <martin_adamek@netbeans.org>
Log: #124886: java.lang.AssertionError: Line number is higher than lines in text
Comment 7 Lukas Jungmann 2008-09-29 11:55:31 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo