Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 124869 - Package/folder not deleted by safe delete
Package/folder not deleted by safe delete
Status: VERIFIED DUPLICATE of bug 97072
Product: java
Classification: Unclassified
Component: Refactoring
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: _ bharathch
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 09:34 UTC by Jiri Skrivanek
Modified: 2008-03-17 12:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2008-01-08 09:34:24 UTC
Package/folder is not deleted because safe delete removes only sources. It started to happen since build 200801071200
where Safe Delete dialog is opened instead of Confirm Object Deletion on a package. To reproduce:

- create a java project
- create a new package (e.g. javaapplication.newpackage)
- copy Main.java into newpackage
- call Delete action on javaapplication.newpackage node and Safe Delete dialog is opened
- click OK and Main.java is removed but javaapplication.newpackage remains

Product Version: NetBeans IDE Dev (Build 20080107122025)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)
Userdir: D:\Development\builds\nbUserdir-20080108100648
Comment 1 Jan Becicka 2008-01-08 15:47:44 UTC
Bharath, this is the one you emailed me about.
Comment 2 _ bharathch 2008-01-18 15:16:41 UTC
Working on it now.
Comment 3 _ bharathch 2008-03-16 14:22:01 UTC

*** This issue has been marked as a duplicate of 97072 ***
Comment 4 Jiri Skrivanek 2008-03-17 12:33:33 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo