Bug 124651 - FAST: Cannot import External XSDs from Windows network share
FAST: Cannot import External XSDs from Windows network share
Status: RESOLVED DUPLICATE of bug 46813
Product: xml
Classification: Unclassified
Component: Schema Tools
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Sonali Kochar
issues@xml
FAST:FOUNDIN:SIERRA-MS4 FAST:POC:CEW4...
:
Depends on: 124985
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-03 16:25 UTC by lpolycarpou
Modified: 2008-01-24 18:30 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lpolycarpou 2008-01-03 16:25:58 UTC
We are trying to import some XSDs into a BPEL project using "New File-->New External XSD Schema Location". Trying to
import External XSDs using a shared network folder on Windows does not seem to be supported when using either the URL or
the "From Local File System" option.  The files do not appear when specifying a Windows share using the \\host\share
notation.  Also, the dialogue becomes somewhat unresponsive when this is attempted.
Comment 1 Sonali Kochar 2008-01-09 18:46:55 UTC
I mapped my unix home directory to a drive on the windows PC. I then used the "From Local File System" Browse button to
navigate to the desired folder on the mapped network drive and was able to import the XSD file. Didnt see any issue nor
did the dialog become unreponsive.

I typed the following in the "From Local File System" text area:
\\host\share\dir_name

and can see that the code tries to copy the file but runs into an issue. There seems to be an issue with core and have
filed the following bug:
[Issue 124985] New - FileUtil.toFileObject() returns null for network shared file

Where using the "From URL" is concerned, you cant use \\host\share there. You need to have a http location.

Please use the workaround of mapping the shared network folder to a drive on the PC and you should be able to import the
XSDs
Comment 2 Mikhail Matveev 2008-01-09 19:14:37 UTC
I got same results as Sonali.
Comment 3 Sonali Kochar 2008-01-24 18:30:00 UTC
This bug depends on 124985 and will be fixed whenever 124985 will be fixed. There is no bug fix required from our
side..Closing as dup as discussed in XML iteam

*** This issue has been marked as a duplicate of 46813 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo