Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 124622 - Ruby Gems error
Ruby Gems error
Status: RESOLVED DUPLICATE of bug 122593
Product: ruby
Classification: Unclassified
Component: Gems
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Martin Krauskopf
issues@ruby
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-03 04:00 UTC by chrisbenson
Modified: 2008-01-03 14:02 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chrisbenson 2008-01-03 04:00:18 UTC
When I try to use Ruby Gems from within Netbeans, I get this exception, and don't know how to fix it:

Bulk updating Gem source index for: http://gems.rubyforge.org
Exception in thread "main" java.lang.OutOfMemoryError: Java heap space
	at org.jruby.util.ByteList.grow(ByteList.java:496)
	at org.jruby.util.ByteList.append(ByteList.java:114)
	at org.jruby.util.ByteList.append(ByteList.java:120)
	at org.jvyamlb.ScannerImpl.update(ScannerImpl.java:330)
	at org.jvyamlb.ScannerImpl.ensure(ScannerImpl.java:350)
	at org.jvyamlb.ScannerImpl.scanLineBreak(ScannerImpl.java:581)
	at org.jvyamlb.ScannerImpl.scanToNextToken(ScannerImpl.java:562)
	at org.jvyamlb.ScannerImpl.fetchMoreTokens(ScannerImpl.java:488)
	at org.jvyamlb.ScannerImpl.peekToken(ScannerImpl.java:411)
	at org.jvyamlb.ParserImpl$ProductionEnvironment.produce(ParserImpl.java:355)
	at org.jvyamlb.ParserImpl.parseStreamNext(ParserImpl.java:730)
	at org.jvyamlb.ParserImpl.peekEvent(ParserImpl.java:681)
	at org.jvyamlb.ComposerImpl.composeNode(ComposerImpl.java:161)
	at org.jvyamlb.ComposerImpl.composeNode(ComposerImpl.java:167)
	at org.jvyamlb.ComposerImpl.composeNode(ComposerImpl.java:167)
	at org.jvyamlb.ComposerImpl.composeDocument(ComposerImpl.java:100)
	at org.jvyamlb.ComposerImpl.getNode(ComposerImpl.java:76)
	at org.jvyamlb.BaseConstructorImpl.getData(BaseConstructorImpl.java:97)
	at org.jruby.RubyYAML.load(RubyYAML.java:221)
	at org.jruby.RubyYAMLInvokerSload1.call(Unknown Source)
	at org.jruby.runtime.callback.FastInvocationCallback.execute(FastInvocationCallback.java:49)
	at org.jruby.internal.runtime.methods.SimpleCallbackMethod.call(SimpleCallbackMethod.java:81)
	at org.jruby.evaluator.EvaluationState.callNode(EvaluationState.java:571)
	at org.jruby.evaluator.EvaluationState.evalInternal(EvaluationState.java:207)
	at org.jruby.evaluator.EvaluationState.orNode(EvaluationState.java:1465)
	at org.jruby.evaluator.EvaluationState.evalInternal(EvaluationState.java:339)
	at org.jruby.evaluator.EvaluationState.eval(EvaluationState.java:164)
	at org.jruby.internal.runtime.methods.DefaultMethod.internalCall(DefaultMethod.java:142)
	at org.jruby.internal.runtime.methods.DynamicMethod.call(DynamicMethod.java:79)
	at org.jruby.evaluator.EvaluationState.fCallNode(EvaluationState.java:1025)
	at org.jruby.evaluator.EvaluationState.evalInternal(EvaluationState.java:253)
	at org.jruby.evaluator.EvaluationState.blockNode(EvaluationState.java:533)
Comment 1 Martin Krauskopf 2008-01-03 14:02:38 UTC
Hi Chris. This was already fixed. See the dupe. The fix is available in 6.1 daily builds.

*** This issue has been marked as a duplicate of 122593 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo