Bug 124552 - I18N - I can not choose input method under Linux.
I18N - I can not choose input method under Linux.
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: -- Other --
6.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-02 01:09 UTC by hahayi
Modified: 2008-01-10 14:41 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hahayi 2008-01-02 01:09:31 UTC
I can not choose input method under Linux !
OS:Ubuntu 7.10 
Language: Chinese
Comment 1 Jiri Prox 2008-01-02 08:38:06 UTC
Does it works for other java applications? (e.g. Notepad.jar in jdk home directory)
Comment 2 Vitezslav Stejskal 2008-01-02 14:30:12 UTC
How do you change input methods? Is this a problem in linux, jdk or Netbeans? As jiriprox suggested, could you please
try with java Notepad and some native applications as well? Thanks

For java Notepad, please run: java -jar $JAVA_HOME/demo/jfc/Notepad/Notepad.jar
Comment 3 Vitezslav Stejskal 2008-01-10 11:53:13 UTC
hahayi, more info on this please?

Ken, Masaki, have we tried reproducing this? I'm sorry, but as usually I only have very vague idea what the defect is
about and without further assistance I will have to close it as INVALID. Thanks a lot
Comment 4 Masaki Katakai 2008-01-10 12:22:29 UTC
Hi Vita and hahayi,

I understand it's expected behavior and it's common for Java/Swing.

I understand that the input method selection will be enabled when
the clients are using IIIMP/SCIM - input method framework. But
Java/Swing/NetBeans is still using XIMP for input method on Linux,
so I think the feature is not usable.
Comment 5 Vitezslav Stejskal 2008-01-10 14:17:39 UTC
Is there anything on Netbeans side we can do to start using IIIMP/SCIM? Or is this solely up the Java/Swing? If latter,
are you aware of any plans/timeframe; is this tracked as an issue for JDK? Thanks
Comment 6 Masaki Katakai 2008-01-10 14:23:35 UTC
I don't think it's possible to use them with NetBeans now.

I understand that IIIMP is now not so common on Linux.
There is an RFE of SCIM support in JDK side and I understand
it's being tracked.

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6469064


Comment 7 Vitezslav Stejskal 2008-01-10 14:41:38 UTC
I see, thanks a lot for this information, Masaki.

hahayi, please keep an eye on the JDK bug to see the progress in this area. Since there is nothing we could do to fix
this in Netbeans I am closing this report as WONTFIX. Thanks


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo