Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 124526 - Auto-Formatting changes the semantic of the program.
Auto-Formatting changes the semantic of the program.
Status: RESOLVED DUPLICATE of bug 123258
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
6.x
All All
: P1 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-30 19:46 UTC by gaflach
Modified: 2007-12-30 20:17 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gaflach 2007-12-30 19:46:32 UTC
There are a bug when auto-formatting nested if statements, which changes the semantics of the program. The auto-
formatting tool changes the following code

if ( ... ) {
  if ( ... )
    command
}
else
  command 

to

if ( ... )
  if ( ... )
    command
else
  command

which are not semantically equal to the first one.
Comment 1 Jan Lahoda 2007-12-30 20:17:29 UTC
Already reported and fixed as issue #123258. Thanks for the report.

*** This issue has been marked as a duplicate of 123258 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo