Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 124482 - OutOfMemoryError: Java heap space
OutOfMemoryError: Java heap space
Status: VERIFIED DUPLICATE of bug 126206
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 126976 (view as bug list)
Depends on: 126206
Blocks: 126977
  Show dependency treegraph
 
Reported: 2007-12-27 21:02 UTC by habib44
Modified: 2008-10-10 10:32 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.90 KB, text/plain)
2007-12-27 21:02 UTC, habib44
Details
stacktrace (2.90 KB, text/plain)
2008-02-22 09:40 UTC, suresh111_mca
Details
stacktrace (2.90 KB, text/plain)
2008-02-23 05:56 UTC, suresh111_mca
Details
stacktrace (2.97 KB, text/plain)
2008-04-08 21:04 UTC, axiomsofchoice
Details
stacktrace (2.51 KB, text/plain)
2008-06-06 15:14 UTC, gregorytechsoft
Details
stacktrace (3.00 KB, text/plain)
2008-08-02 19:14 UTC, nvarun
Details

Note You need to log in before you can comment on or make changes to this bug.
Description habib44 2007-12-27 21:02:54 UTC
Build: NetBeans IDE Dev (Build 200711050000)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows XP, 5.1, x86

User Comments:
Comment 1 habib44 2007-12-27 21:02:59 UTC
Created attachment 54539 [details]
stacktrace
Comment 2 Lukas Hasik 2008-02-08 09:08:47 UTC
at org.openide.xml.XMLUtil.parse(XMLUtil.java:326)
        at
org.netbeans.modules.autoupdate.updateprovider.AutoupdateCatalogParser.getDocument(AutoupdateCatalogParser.java:192)
        at
org.netbeans.modules.autoupdate.updateprovider.AutoupdateCatalogParser.getLicenses(AutoupdateCatalogParser.java:129)
       
Comment 3 suresh111_mca 2008-02-22 09:40:20 UTC
Build: NetBeans IDE Dev (Build 200801280931)
VM: Java HotSpot(TM) Client VM, 10.0-b19
OS: Windows XP, 5.1, x86

User Comments: 
Comment 4 suresh111_mca 2008-02-22 09:40:31 UTC
Created attachment 57043 [details]
stacktrace
Comment 5 suresh111_mca 2008-02-23 05:56:56 UTC
Build: NetBeans IDE Dev (Build 200801280931)
VM: Java HotSpot(TM) Client VM, 10.0-b19
OS: Windows XP, 5.1, x86

User Comments: 
Comment 6 suresh111_mca 2008-02-23 05:56:59 UTC
Created attachment 57123 [details]
stacktrace
Comment 7 Exceptions Reporter 2008-03-04 20:16:42 UTC
This issue has already 20 duplicates 
Comment 8 axiomsofchoice 2008-04-08 21:04:04 UTC
Build: NetBeans IDE Dev (Build 200804050004)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_04-b12
OS: Windows XP, 5.1, x86

User Comments: 
Was checking for updates
Comment 9 axiomsofchoice 2008-04-08 21:04:12 UTC
Created attachment 59872 [details]
stacktrace
Comment 10 Jiri Rechtacek 2008-04-16 12:00:31 UTC
*** Issue 126976 has been marked as a duplicate of this issue. ***
Comment 11 Exceptions Reporter 2008-05-04 04:14:05 UTC
This issue has already 10 duplicates 
Comment 12 gregorytechsoft 2008-06-06 15:14:29 UTC
Created attachment 62473 [details]
stacktrace
Comment 13 gregorytechsoft 2008-06-13 07:48:45 UTC
The Java process consumes a great amount of system resources, and eventually ends up running to nearly 100% of cpu 
load - just sitting there, doing nothing. I have tended to think (n the recent past, at least) the problem might be 
either with versioning integration, as I also am having trouble commiting code to my SourceForge project, or with 
oddities in module projects dropping dependencies.

Win XP sp3
512 MB ram, 753 MB swap
1.6GHz proc
NetBeans 6.1 + very few 3rd party modules
-J-Xmx=128m in config for startup
Comment 14 Exceptions Reporter 2008-07-03 07:37:55 UTC
This issue has already 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=11923
Comment 15 Exceptions Reporter 2008-07-14 12:22:50 UTC
This issue has already 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=5618
Comment 16 nvarun 2008-08-02 19:14:09 UTC
Build: NetBeans IDE Dev (Build 200808010201)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_05-b13
OS: Windows XP, 5.1, x86

User Comments: 
Plugin Manager was loading while Tomcat Server was running

Stacktrace: 
java.lang.OutOfMemoryError: Java heap space
        at com.sun.org.apache.xerces.internal.util.XMLStringBuffer.append(XMLStringBuffer.java:205)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.refresh(XMLDocumentScannerImpl.java:1501)
        at com.sun.org.apache.xerces.internal.impl.XMLEntityScanner.invokeListeners(XMLEntityScanner.java:2070)
        at com.sun.org.apache.xerces.internal.impl.XMLEntityScanner.peekChar(XMLEntityScanner.java:486)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2672)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:647)
Comment 17 nvarun 2008-08-02 19:14:19 UTC
Created attachment 66394 [details]
stacktrace
Comment 18 Jiri Rechtacek 2008-08-11 14:48:12 UTC
fixed in NB6.5. DOM parser was replaces by SAX parser in changeset c3671f6adc67
dupl of 126206

*** This issue has been marked as a duplicate of 126206 ***
Comment 19 Jaromir Uhrik 2008-10-10 10:32:48 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo