Bug 124338 - Allow reinstallation even if the .nbm version is same
Allow reinstallation even if the .nbm version is same
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Tulach
au-issues
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-20 19:53 UTC by mgrev
Modified: 2010-10-29 17:19 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mgrev 2007-12-20 19:53:28 UTC
When developing a plugin it must be tested again and again. The problem is that when the netbeans module is regenerated it will not be accepted if it hasn't 
got a higher version number. Net even if I manually point out it can I install it. It should ask me if I want to install it even though it is the same version. I think 
that netbeans should even ask me if I want to update if it reads that the timestamp on the file has increased.
Comment 1 mgrev 2007-12-20 19:56:22 UTC
To clarify, the problem is that the versioning of the plugin will get out of sync with the intended versioning on the module, just because of testing. This is not 
desired.
Comment 2 David Botterill 2007-12-20 20:12:01 UTC
This issue you talk about is related to the NetBeans core when doing module development.  The "pluginportal" component
is for problems adding/changing plugins on the Plugin Portal web site at http://plugins.netbeans.org/PluginPortal.
Comment 3 Jesse Glick 2008-04-10 16:54:45 UTC
Normally you would not be testing a module by installing an NBM; the module development support is designed to have you
test the target platform with an unpacked module.

That said, the Plugin Manager should probably special-case the handling of NBMs pointed to in the Downloaded tab, and
always install them even if the module already appears to be installed in the same (or later?) version.
Comment 4 Jiri Rechtacek 2008-04-10 17:02:28 UTC
I think it makes sense in plugin's developing phase. Something like Reinstall option in Download tab.
Comment 5 Antonin Nebuzelsky 2008-11-14 15:33:01 UTC
Reassigning to the new "autoupdate/*" owner dlipin.
Comment 6 Jaroslav Tulach 2010-10-29 17:19:43 UTC
I am not going to spend time on this, but I am ready to accept a patch.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo