Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 124261 - Ignored file not reported as ignored
Ignored file not reported as ignored
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
Sun All
: P3 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-19 12:08 UTC by Padraig Obriain
Modified: 2008-01-03 09:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
proposed patch (1.04 KB, patch)
2007-12-19 12:11 UTC, Padraig Obriain
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Padraig Obriain 2007-12-19 12:08:40 UTC
An ignored file is not dislayed as ignored.
Comment 1 Padraig Obriain 2007-12-19 12:11:51 UTC
Created attachment 54394 [details]
proposed patch
Comment 2 Padraig Obriain 2007-12-19 12:13:06 UTC
The problem is that status change is not fired for excluded file when getScannedFiles is called for the parent of the file.
Comment 3 Padraig Obriain 2007-12-19 12:15:18 UTC
IDE:-------------------------------------------------
IDE: [12/19/07 12:14 PM] Committing "FileStatusCache.java" started
Checking in FileStatusCache.java;
/shared/data/ccvs/repository/versioncontrol/mercurial/src/org/netbeans/modules/mercurial/FileStatusCache.java,v  <-- 
FileStatusCache.java
new revision: 1.21; previous revision: 1.20
done
IDE: [12/19/07 12:14 PM] Committing "FileStatusCache.java" finished


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo